• PCMod Release - In Game PCs and Networks
    312 replies, posted
  • Avatar of Valeour
  • There's already a stargate program. [url]http://www.garrysmod.org/downloads/?a=view&id=51952[/url] There you go.
  • Avatar of Choppie
  • [QUOTE=Valeour]There's already a stargate program. [url]http://www.garrysmod.org/downloads/?a=view&id=51952[/url] There you go.[/QUOTE] Won't it clash with PCMod v1.0.0 as it was made when PCMod was in the beta stages?
  • Avatar of Penguiin
  • Awesome, someone needs to make a gmod program so I can play gmod while I'm playing gmod!
  • Avatar of Choppie
  • [QUOTE=Penguiin]Awesome, someone needs to [b]make a gmod program[/b] so I can play gmod while I'm playing gmod![/QUOTE] That'd be extremely hard, if not impossible. I've only just started learning Lua, and it already seems rather difficult (especially when its 3 in the morning ;) ).
  • Avatar of Yuki MK 6
  • [QUOTE=Choppie]That'd be extremely hard, if not impossible. I've only just started learning Lua, and it already seems rather difficult (especially when its 3 in the morning ;) ).[/QUOTE] He was joking. I suggest the ability to save files. Using the File-Finder thing is worthless without that ability.
  • Avatar of zc_guy
  • [QUOTE=Penguiin]Awesome, someone needs to make a gmod program so I can play gmod while I'm playing gmod![/QUOTE] Yo dawg! We heard you like gmod, so we put a gmod in your gmod so you can play gmod while you play gmod!
  • Avatar of Valeour
  • Heh, and Choppie, It might do and it might not, I highly doubt that it will clash, because for a clash to happen, you'd probably need a diffrent program all together. I dunno, a test won't hurt.
  • Avatar of nfrick
  • Cool, I'll give it a try now, but I have to go to Karate class:)Cool!
  • Avatar of RazorOfDeath
  • That... is... AWESOME! Are you still going to make the computers hackable in latter releases?
  • Avatar of benjgvps
  • One question: What the heck does the repeater do? Other than that, YAY! I just hope that the GChat server actually works in this version (One thing I haven't tried). EDIT: Major bug on my server, I will try to get a screenshot in a bit. Only a few options are displayed in the PCMod tab... And when I try to spawn them I get [code] sandbox\gamemode\spawnmenu\controlpanel.lua:99: ControlPanelBuildFunction Error: weapons\gmod_tool\stools/routerlinker.lua:110: attempt to call global 'pc_maketoolinfo' (a nil value) [/code] EDIT2: [IMG]http://i206.photobucket.com/albums/bb271/benjgvps/rp_downtown_v20011.jpg[/IMG] [IMG]http://i206.photobucket.com/albums/bb271/benjgvps/rp_downtown_v20012.jpg[/IMG]
  • Avatar of blu-dave
  • Wow when are you going to make games for it? and can you able to go on the real network or the "ingame" network or you make a new thing for it so it able to go on the real network and if that happen then what? ooo and 5 out of 5 stars!
  • Avatar of Rice062
  • Anyone Else having issues with this version hosting it on a server. The Entities load just when clients try to open the OS nothing happens Console Errors [code]== PCMod Clientside OS Loaded == autorun/client/cl_pcmod_achat.lua:106: attempt to call method 'Register' (a nil value) autorun/client/cl_pcmod_console.lua:94: attempt to call method 'Register' (a nil value) autorun/client/cl_pcmod_gchat.lua:115: attempt to call method 'Register' (a nil value) autorun/client/cl_pcmod_mycomputer.lua:82: attempt to call method 'Register' (a nil value) autorun/client/cl_pcmod_pinger.lua:58: attempt to call method 'Register' (a nil value) autorun/client/cl_pcmod_routermaster.lua:61: attempt to call method 'Register' (a nil value) autorun/client/cl_pcmod_wireclient.lua:85: attempt to call method 'Register' (a nil value)[/code]
  • Avatar of benjgvps
  • [QUOTE=Rice062]Anyone Else having issues with this version hosting it on a server. The Entities load just when clients try to open the OS nothing happens Console Errors [code]== PCMod Clientside OS Loaded == autorun/client/cl_pcmod_achat.lua:106: attempt to call method 'Register' (a nil value) autorun/client/cl_pcmod_console.lua:94: attempt to call method 'Register' (a nil value) autorun/client/cl_pcmod_gchat.lua:115: attempt to call method 'Register' (a nil value) autorun/client/cl_pcmod_mycomputer.lua:82: attempt to call method 'Register' (a nil value) autorun/client/cl_pcmod_pinger.lua:58: attempt to call method 'Register' (a nil value) autorun/client/cl_pcmod_routermaster.lua:61: attempt to call method 'Register' (a nil value) autorun/client/cl_pcmod_wireclient.lua:85: attempt to call method 'Register' (a nil value)[/code][/QUOTE] Ah, I get that too.
  • Avatar of Rice062
  • It seems the clients can not have an older version of Pcmod Installed when they joined. Fixed it when i told them to remove it
  • Hey, I don't have a server - but I want to suggest this to the Head Admins of an RP server I play on to put this in... Is possible to have EVERYTHING in this serverside? So that 'newbies' don't see errors? I know this seem's like a dumb question but as long as I get my answer - meh... *Oh god... I linked this page to the server forums - they're all going to see my dumb question!!!*
  • Avatar of Computer22
  • You can forward it to the Client, then they download it if they join the server. Edit: Is it possible that anyone make a "PC-Mod Weapon", cause i don't want to give my Users on the RP-Server any Toolgun.
  • Avatar of Jowel
  • Could You center the image of the desktop on the tv, It appears to me that it is a little bit too much to the left.
  • Avatar of thomasfn
  • All the Lua files have been added correctly using AddCSLuaFile. The problem is, that V13 has files in autorun that run regardless of what version server has. So the only fix is to get people to delete their V13s.
  • Avatar of benjgvps
  • [QUOTE=thomasfn]All the Lua files have been added correctly using AddCSLuaFile. The problem is, that V13 has files in autorun that run regardless of what version server has. So the only fix is to get people to delete their V13s.[/QUOTE] The odd thing is that when I go on your build server PCMod works perfectly, though when I go on my server it does not. PCMod works fine in single player so it isn't me. Also when I join my server every time it downloads around 7 or 8 Lua files relating to PCMod... Could there be something conflicting with it?
  • Avatar of thomasfn
  • [QUOTE=benjgvps]The odd thing is that when I go on your build server PCMod works perfectly, though when I go on my server it does not. PCMod works fine in single player so it isn't me. Also when I join my server every time it downloads around 7 or 8 Lua files relating to PCMod... Could there be something conflicting with it?[/QUOTE] Hmm, try deleting your "Dua" folder in the "Cache" folder on your server.
  • Avatar of kp3
  • Someone need to make a module so that we can run active x controls inside gmod. Simple games, And media. Webbrowsers, that are working good. This would probably need a bit coding, but it would be cool if you could make any form of 2d3d thing so that you can use your laptop without going into a hud, but just looking at it like the wire console menu thing.
  • Avatar of blu-dave
  • [QUOTE=Rice062]Anyone Else having issues with this version hosting it on a server. The Entities load just when clients try to open the OS nothing happens Console Errors [code]== PCMod Clientside OS Loaded == autorun/client/cl_pcmod_achat.lua:106: attempt to call method 'Register' (a nil value) autorun/client/cl_pcmod_console.lua:94: attempt to call method 'Register' (a nil value) autorun/client/cl_pcmod_gchat.lua:115: attempt to call method 'Register' (a nil value) autorun/client/cl_pcmod_mycomputer.lua:82: attempt to call method 'Register' (a nil value) autorun/client/cl_pcmod_pinger.lua:58: attempt to call method 'Register' (a nil value) autorun/client/cl_pcmod_routermaster.lua:61: attempt to call method 'Register' (a nil value) autorun/client/cl_pcmod_wireclient.lua:85: attempt to call method 'Register' (a nil value)[/code][/QUOTE] I never got that, I just put the lua file with the lua and sound with sound and you get it, but before I do that i make a copy of it and put it in addons and then do that so i have two of them if one go buggy i can just use the other one. and I don't have do anything then, like with the lua, sound and the others but the addons one I have to delete
  • Avatar of benjgvps
  • [QUOTE=thomasfn]Hmm, try deleting your "Dua" folder in the "Cache" folder on your server.[/QUOTE] Just finished doing that. Still have the issue. Very odd. If you want to see it for yourself my server is here: [url=http://www.game-monitor.com/garrysmod2_GameServer/67.204.198.224:27015/247_RP_DownTown_V2_Hosted_By_Ben.html][img]http://module.game-monitor.com/67.204.198.224:27015/image/default/default.png[/img][/url]
  • ha ha ha. well done tom but can you get rid of the message "this server uses pcmod addon" bla bla because it's really annoying
  • Avatar of benjgvps
  • Full error on my server console: [code] KeyValues Error: RecursiveLoadFromBuffer: got EOF instead of keyname in file dels/GraffitiRTST/creative_woofer.mdl mdlkeyvalue, (*prop_data*), KeyValues Error: RecursiveLoadFromBuffer: got EOF instead of keyname in file dels/GraffitiRTST/creative_woofer.mdl mdlkeyvalue, (*prop_data*), KeyValues Error: RecursiveLoadFromBuffer: got EOF instead of keyname in file dels/GraffitiRTST/creative_volume.mdl mdlkeyvalue, (*prop_data*), KeyValues Error: RecursiveLoadFromBuffer: got EOF instead of keyname in file dels/GraffitiRTST/creative_volume.mdl mdlkeyvalue, (*prop_data*), [resource.AddFile] File models\laptop\laptop.ani didn't exist! [resource.AddFile] File models\laptop\laptop.jpg didn't exist! [resource.AddFile] File models\GraffitiRTST\creative_woofer.ani didn't exist! [resource.AddFile] File models\GraffitiRTST\creative_woofer.jpg didn't exist! [resource.AddFile] File models\GraffitiRTST\creative_volume.ani didn't exist! [resource.AddFile] File models\GraffitiRTST\creative_volume.jpg didn't exist! [/code] Hope this helps solve the problem! People are really wanting to use this version of PCMod on my roleplay server, any other advice or tips would be wonderful.
  • Avatar of thomasfn
  • [QUOTE=benjgvps]Full error on my server console: [code] KeyValues Error: RecursiveLoadFromBuffer: got EOF instead of keyname in file dels/GraffitiRTST/creative_woofer.mdl mdlkeyvalue, (*prop_data*), KeyValues Error: RecursiveLoadFromBuffer: got EOF instead of keyname in file dels/GraffitiRTST/creative_woofer.mdl mdlkeyvalue, (*prop_data*), KeyValues Error: RecursiveLoadFromBuffer: got EOF instead of keyname in file dels/GraffitiRTST/creative_volume.mdl mdlkeyvalue, (*prop_data*), KeyValues Error: RecursiveLoadFromBuffer: got EOF instead of keyname in file dels/GraffitiRTST/creative_volume.mdl mdlkeyvalue, (*prop_data*), [resource.AddFile] File models\laptop\laptop.ani didn't exist! [resource.AddFile] File models\laptop\laptop.jpg didn't exist! [resource.AddFile] File models\GraffitiRTST\creative_woofer.ani didn't exist! [resource.AddFile] File models\GraffitiRTST\creative_woofer.jpg didn't exist! [resource.AddFile] File models\GraffitiRTST\creative_volume.ani didn't exist! [resource.AddFile] File models\GraffitiRTST\creative_volume.jpg didn't exist! [/code] Hope this helps solve the problem! People are really wanting to use this version of PCMod on my roleplay server, any other advice or tips would be wonderful.[/QUOTE] That's all model errors. Are there any Lua based errors? (That complain with a line number) If not, try deleting your entire PCMod folder (on the server) and re-extracting the zip file for it.