• WAC - WeltEnSTurm's Addon Compilation
    421 replies, posted
  • Avatar of filipegroh
  • The mod works really great, but just now, a weird bug started to happen, it seem that the turrets controls are inverted, so if I wanna make it work right, I must invert it (place, for example, the custom weapon on the back part of the mount), besides that, didn't find anyother bug. Here are a few sugestions: Small base mount: Currently thare aren't any base mounts that small, all of them are bigger them a 4x4 phx plate, adding a new base mount about the size of the signpost would be a good idea. Train threads: Instead of having only one wire imput, called speed, add 4: forward(1) , forward(2), backward(1) , backward (2), this way you could wire, for example: W -> forward(1), both threads ; S -> backward(1), both threads ; A -> forward(2) on the right thread and backward(2) on the left thread ; D -> Backward(2) on the right thread and forward(2) on the left thread ; This way you could make the tank move realistically without having to use E2 About the WAC weapons, they're awsome, but an option to enable free aim on all weapons but the toolgun and the physgun would be nice. EDIT: The hl2 shotgun secondary fire fires both barrels at the same time, plus it enters iron sight, remove it, or make it so you have to press E+MOUSE1 to fire both barrels.
  • Avatar of MagicChocolate7
  • I have one suggestion and that would be to remove the freeaim with the physgun and toolgun when freeaim with all weapons is enabled. Also, I keep getting this bug where if i am in the passenger seat of a helicopter I can't hear the rotor blades.
  • Avatar of TheLolrus
  • I like the new controls for the helicopter, but I can't land without rolling over or taking damage.
  • Avatar of BoxMonster
  • the "seat switcher" entity spams lua errors whenever i try to link it with a pod, something about "getpassenger" not existing. i can take another look tomorrow (EST) if you like, but i strongly doubt it's an addon conflict, so i'm probably not the only person with that problem. maybe.
  • Avatar of King Kambroo
  • I'm really liking this addon, keep up the good work! I think what would really help this succeed would be increased support for adv dupe on things like seat switchers and cameras. Only major bug I've found is that the seat switcher spams [QUOTE]...ns\wac base\lua\entities\wac_v_connector\cl_init.lua:21: attempt to call method 'GetPassenger' (a nilvalue)[/QUOTE] when it's connecting to a vehicle such as a jeep or airboat
  • Avatar of WeltEnSTurm
  • What doesn't work with Adv-Dupe saving? They should properly save what they are connected to. Also, fixed the error spam on non-prisonerpod vehicles. [editline]10:32AM[/editline] I see.. what the hell, this worked before. [editline]10:35AM[/editline] And whoops, works again.
  • Avatar of minhmap512
  • Well, welt, I seem can't change Wac base player speed and things like that on my dedicated server :-?. Any help ? Anyway, what is the ammo limit :-?. It's look great :3
  • Avatar of XxAthrunxX
  • So you finally released it to the public :v: I've been using it ever since you gave me the link to the svn on youtube. Anyways I love it,it is the best addon I've ever seen for gmod.
  • Avatar of WeltEnSTurm
  • [QUOTE=minhmap512;24183763]Well, welt, I seem can't change Wac base player speed and things like that on my dedicated server :-?. Any help ? Anyway, what is the ammo limit :-?. It's look great :3[/QUOTE] You can't change server replicated convars from clientside menus. You'll have to do this with rcon or on the server console itself. I'll make a list with commands. For player speed, use wac_walkm_walkspeed and wac_walkm_runspeed. [editline]07:57PM[/editline] [code] wac_walkm_enable wac_walkm_walkspeed wac_walkm_runspeed wac_walkm_jumpp --jumping power, default 200 wac_walkm_update --applies settings immediately, else you have to wait until respawn wac_healthmod wac_healthstart --time it takes after taking damage until health recharges wac_maxhealth --to what value should it recharge? also, player health it set at this at spawn wac_healthtime --health recharge rate, 0.1 is 10 per second, set to 0 to disable health recharge wac_maxarmor --same as maxhealth, but armor wac_armortime --same as healthtime, but armor wac_damage_npc --damage multiplicator given to npcs (1 is normal) wac_damage_player --same as npc, but player wac_falldamage --multiplies falldamage wac_damage_customsnd --disable beep and enable death screams on death wac_addtag --add a server tag wac_removetag --remove a server tag wac_ammomod_enable --enable ammo limits wac_ammomod_max*ammotype* --change limit of ammotype wac_reload --reloads wac serverside, useful if hooks are broken wac_headshotfix_enable --lowers headshot damage multiplicator to npcs from 10 to 2 (you don't want to kill a zombie with the pistol with one headshot, do you?) [/code]
  • Avatar of minhmap512
  • Nah, another problem in multi :-?. When i shoot my WAC BASE weapon, the shoot hole decal seem don't have :-?. Only get this problem in Wac SWEP. Don't know what did it. Normal weapon seen shoot okay.
  • Avatar of BoxMonster
  • Hey, Welt... Whenever you spawn a pod-linked WAC turret via Adv Dupe, the Yaw becomes reversed (offset by 180 degrees). So if I look up, it'll look up, but backwards. Bit of a problem... Fixable? One last thing: Can you make the seat-switcher compatible with [url="http://www.facepunch.com/showthread.php?t=882698"]Weapon Seats[/url]? The Entity Linker works just fine on them, but trying to switch to one gives a single Lua error. Don't remember what it is, but I can look into it if you like.
  • Avatar of Imanoob
  • Please help me Welt,im getting consoled spammed and all of the entities dont work :/ [img]http://filesmelt.com/dl/gm_construct000012345678910111213141516171819202122232425262728.jpg[/img] [img]http://filesmelt.com/dl/gm_construct00011234567891011121314151617181920212223242526.jpg[/img] [img]http://filesmelt.com/dl/gm_construct0002123456789101112.jpg[/img]
  • Avatar of Marlwolf78
  • [QUOTE=Flubadoo;24209672]Wait there is an ironsights editor in this pack?[/QUOTE] There is with the new SVN.
  • Avatar of minhmap512
  • Please, welt.... I hate to say like a dumbass but yeah.... There-is-no-any-decal-on-multi ! In singleplay it's work great, but well, in multi, you Wac base weapon seem don't make any bullet hole or things like blood. Here is the comparison: [url]http://cA4.upanh.com/11.1014.16219493.DZL0/gm_flatgrass2010_v20035.jpg[/url] Any help ? :((. And well, how to make shotgun have reload animation ? :3
  • Avatar of Imanoob
  • [QUOTE=BoxMonster;24212533]Do you have WireMod, Imanoob?[/QUOTE] Do i need it?
  • Avatar of Flubadoo
  • [QUOTE=Marlwolf78;24218751]There is with the new SVN.[/QUOTE] Does it work like devenger's ironsight designer? Also, I can't seem to find it.
  • Avatar of BoxMonster
  • [QUOTE=Imanoob;24228126]Do i need it?[/QUOTE] Yeah, at least for the tank treads, and almost all of the other WAC SEnts have Wire inputs. You don't have to use Wire, but I think you need it for WAC to function properly. Plus, Wire is amazing. :P
  • Avatar of shoe
  • [QUOTE=minhmap512;24227389]Please, welt.... I hate to say like a dumbass but yeah.... There-is-no-any-decal-on-multi ! In singleplay it's work great, but well, in multi, you Wac base weapon seem don't make any bullet hole or things like blood. Here is the comparison: [url]http://cA4.upanh.com/11.1014.16219493.DZL0/gm_flatgrass2010_v20035.jpg[/url] Any help ? :((. And well, how to make shotgun have reload animation ? :3[/QUOTE] Please read where I first reported this back on page 2. Welt is AWARE of it, but it is not truly his responsibility. It is the fault mainly of Garry... if you like how his ballistics system works, then you're going to have to deal with it. Or code your own client-side hit effects ( Look at the CSS Base Weapons ), otherwise you need to just deal with it. Shotgun animation will require a method like... On Ammo +1, Call animation VM_SHOTGUN_RELOAD, and when Ammo reaches maximum, you could reference defaultclip, Etc.
  • Avatar of minhmap512
  • Oh... Sorry Shoe, just don't get it, so feel free to rate me "dumb". XD Anyway, what will be if wac merge with GDCW ? Epic realistic ? XD
  • Avatar of Imanoob
  • [QUOTE=BoxMonster;24234192]Yeah, at least for the tank treads, and almost all of the other WAC SEnts have Wire inputs. You don't have to use Wire, but I think you need it for WAC to function properly. Plus, Wire is amazing. :P[/QUOTE] installed the wire svn and it worked :P,thanks boxmaster
  • Avatar of Marlwolf78
  • [QUOTE=Flubadoo;24231919]Does it work like devenger's ironsight designer? Also, I can't seem to find it.[/QUOTE] It should be in the SWEPs menu in the options tab. There's a box to tick in there to open the menu and give you the ironsight making SWEP.
  • Avatar of HJ-kos
  • RT7 doesn't work for me, when making new camera old one doesn't disappear, screens show only skybox. And i just don't know how to use seatlinker. I press seatlinker in entities tab and nothing happens.
  • Avatar of BoxMonster
  • [QUOTE=Imanoob;24238631]installed the wire svn and it worked :P,thanks boxmaster[/QUOTE] Awesome! No prob, man.