• WAC - WeltEnSTurm's Addon Compilation
    421 replies, posted
  • Avatar of WeltEnSTurm
  • [QUOTE=Dwatring;24631856]....[/QUOTE] I don't know.. they fuck your framerate anyway. Garry asked for the code and I hope he's on the way to fix it. (Yup, this is not my fault) Did you try it without any addons? You don't have to delete them, just rename your addons- or the whole garrysmod folder. [editline]11:14AM[/editline] [QUOTE=JerrBerr;24627467]I'm also having an issue with that game mode, but instead of having issues in game, I only see a few of the included game modes in the list. I downloaded solely from the SVN, is that the reasoning for all these errors?[/QUOTE] I'll look into it [editline]11:16AM[/editline] [QUOTE=JerrBerr;24598846]Alright, I'll just paste as much WAC related errors that I come across. [CODE] When Starting Server: Hook 'wac_cl_customcrosshair_paint' Failed: WAC\shared\e_weapons.lua:244: attempt to call method 'Zoomed' (a nil value) When zooming in with the two working snipers (m24 and intervention): ClientsideModel cannot be called while rendering weapons\w_wac_base\cl_init.lua:41: attempt to index field 'ScopeModel' (a nil value) When firing the CSS Ak47: Failed to load sound "weapons\jen.ak\fire.wav", file probably missing from disk/repository (this also happens with the FAL reload, with it's own respective sounds) [/CODE]As far as the spawning issue goes, there's not any errors that show up, it's just that the guns don't spawn. The weapons that don't spawn are: [CODE] WAC: SRAW WAC CSS: M3 WAC Tactical: F200, G36, M14, M3, and M4 Aimpoint [/CODE]There are 7 total weapons that don't spawn, and 7 "Scripted Weapon" icons. Hope this helps.[/QUOTE] Fixed the scope model to fix the ak47 sound, you'll have to delete the scripts folder from tactical weapons for the can't spawn issue: I'm sorry, I don't know.
  • Avatar of JerrBerr
  • [QUOTE=WeltEnSTurm;24636138] Fixed the scope model to fix the ak47 sound, you'll have to delete the scripts folder from tactical weapons for the can't spawn issue: I'm sorry, I don't know.[/QUOTE] Well, fortunately they finally started working. So whatever you did, thanks.
  • Avatar of RaZoR_HaX
  • [QUOTE=RaZoR_HaX;24720358]I dont know if this was fixed or not but since the recent update WAC Heli doesnt have any keyboard response anymore, "R" starts it up but WASD and other keyboard functions didnt work, Im reinstalling now but if the Lua Errors come up again after spawning it, you will hear from me again.[/QUOTE] Just had to update... [@addons\wac damagesystem\lua\entities\wac_w_rocket\init.lua:144] bad argument #2 to '?' (Vector expected, got Angle) ^That^ Comes up and spams the command console with no end when you bring out the swep Javelin you have [lua\vgui\dimage.lua:63] Material missing: VGUI/entities/w_wac_mw_ak47 [lua\vgui\dimage.lua:63] Material missing: VGUI/entities/w_wac_mw_interv CMaterial::DrawElements: No bound shader [lua\vgui\dimage.lua:63] Material missing: VGUI/entities/w_wac_mw_fal [lua\vgui\dimage.lua:63] Material missing: VGUI/entities/w_wac_mw_m4 That comes up when you spawn any of your weapons
  • Avatar of Agent_Wesker
  • Would be nice if there was a wac heli combat gamemode where everyone spawns in their own helicopter and has to shoot everyone else down.
  • Avatar of Flubadoo
  • [QUOTE=RaZoR_HaX;24720358]Just had to update... [@addons\wac damagesystem\lua\entities\wac_w_rocket\init.lua:144] bad argument #2 to '?' (Vector expected, got Angle) ^That^ Comes up and spams the command console with no end when you bring out the swep Javelin you have [lua\vgui\dimage.lua:63] Material missing: VGUI/entities/w_wac_mw_ak47 [lua\vgui\dimage.lua:63] Material missing: VGUI/entities/w_wac_mw_interv CMaterial::DrawElements: No bound shader [lua\vgui\dimage.lua:63] Material missing: VGUI/entities/w_wac_mw_fal [lua\vgui\dimage.lua:63] Material missing: VGUI/entities/w_wac_mw_m4 That comes up when you spawn any of your weapons[/QUOTE] Yeah, for the javelin just change the angle to a vector and you're missing a few materials. Redownload the svn.
  • Avatar of WeltEnSTurm
  • Fixed the rocked errors, the "material missing" errors show up because they don't have spawnicons.
  • Avatar of RaZoR_HaX
  • [QUOTE=WeltEnSTurm;24727667]Fixed the rocked errors, the "material missing" errors show up because they don't have spawnicons.[/QUOTE] Alright then Im not all concerned [QUOTE=Flubadoo;24726438]Yeah, for the javelin just change the angle to a vector and you're missing a few materials. Redownload the svn.[/QUOTE] And how would I go about changing the angle to a vector? And this error comes up when you enable the custom crosshair and switch from one of your guns to a gun not of yours Hook 'wac_cl_customcrosshair_paint' Failed: [addons\wac sweps\lua\wac\shared\e_weapons.lua:244] attempt to call method 'Zoomed' (a nil value)
  • Avatar of minhmap512
  • Welt, can you make the "weapon bobbing" customable ? Like a pistol will have less bobbing than a rifle when you move. Please ?
  • Avatar of Black-Ice
  • What do I do to use the SVN link? PHX3 was "Create a folder called PHX3 in your addons" and stuff, so whats this one? WAC?
  • i was just wondering, how did you attach the tracks to the props in the vid, if i weld it dont work so ow else should i do it? also both the modern warfare and the tactical sweps are big errors, could you fix it.
  • Avatar of fstab
  • [QUOTE=Black-Ice;24921086]What do I do to use the SVN link? PHX3 was "Create a folder called PHX3 in your addons" and stuff, so whats this one? WAC?[/QUOTE] Install it like wiremod, create a folder called WAC in addons then SVN checkout the SVN link in that folder. Once it finishes downloading, take all of WAC_* folders (not the .svn one) inside there and put them in addons. Then delete the main WAC folder you downloaded them to.
  • Avatar of Jason_Rally
  • Well I got the WAC helicopter from garrysmod.org and i placed both the WAC base and the WAC helicopter in the addons but when i start a game in singleplayer the spawnmenu breaks and i can't bring it up can someone tell me how to fix that
  • Avatar of watersupreme
  • [QUOTE=Jason_Rally;25072576]Well I got the WAC helicopter from garrysmod.org and i placed both the WAC base and the WAC helicopter in the addons but when i start a game in singleplayer the spawnmenu breaks and i can't bring it up can someone tell me how to fix that[/QUOTE] I think it's because of conflicting addons
  • Avatar of Jason_Rally
  • [QUOTE=watersupreme;25074329]I think it's because of conflicting addons[/QUOTE] Well i took everything out my addons and i found out that WAC sweps causes the problem :( why is that
  • Avatar of Pilot1215
  • Every time i spawn a helicopter the rotors spawn in the middle of it. Anyone else having this problem or know how to fix it.
  • Avatar of WeltEnSTurm
  • [QUOTE=Jason_Rally;25079399]Well i took everything out my addons and i found out that WAC sweps causes the problem :( why is that[/QUOTE] Because you downloaded them from GMod.org, they don't work with newer versions. Gonna upload a new version. Maybe I should delete not working stuff earlier :p
  • Avatar of amplifier
  • Whew, just epic! That's one of the best upgrades my server got after Wiremod and Stargate! You, Sir, deserve the LUA King title! Btw, is there a option to remove the Vehicle Cameras view filter?
  • Avatar of Jason_Rally
  • [QUOTE=WeltEnSTurm;25087111]Because you downloaded them from GMod.org, they don't work with newer versions. Gonna upload a new version. Maybe I should delete not working stuff earlier :p[/QUOTE] Thanks for telling me
  • Avatar of RTM xBEASTx
  • Well this Is the problem. I crash when I spawn the first Little bird. Also why do I miss the materials for the second littlebird. I will try updating the SVN but is anyone else having this problem.
  • Avatar of Marlwolf78
  • Also, Welt, are you planning on adding any new features to the base, such as multiple firemodes?
  • Avatar of creec
  • [QUOTE=Marlwolf78;25093463]Also, Welt, are you planning on adding any new features to the base, such as multiple firemodes?[/QUOTE] [QUOTE=minhmap512;24513280]Welt, can you add the swep "fire mode" ? I'm too noobish to can do it by myself.... :(.[/QUOTE] [QUOTE=WeltEnSTurm;24519020]I am busy with the helicopter, sorry. But it's on my list.[/QUOTE] Np.
  • Avatar of Topher81405
  • Every time I use any weapon that has the different explosion effect (Ex, the helicopter's apache missiles) the game promptly crashes... Any suggestions?
  • Avatar of viperfan7
  • Just wondering if your ever going to add proper support for sharpeye focus into sthe swep pack, maby add something that will tell the sweps to use sharpeye instead of your code.
  • Avatar of minhmap512
  • That is: [url]http://www.facepunch.com/showthread.php?t=908557[/url] Now, the biggest different from Wac and Sharp is Sharp can't FORCE people to use them when they joined the server, but Wac can :>