• SCars
    1,870 replies, posted
  • meybe its the webside causing it. shouldnt be the first time i download a file from that site doing the same thing. try something else like dropbox maybe?
  • Avatar of Matsilagi
  • Downloaded the full pack without errors. I will upload it on my Dropbox. LATE, but, there it is: [url]http://dl.dropbox.com/u/43050980/SCars_2.0_Complete_Pack_.zip[/url]
  • I can't seem to switch from first to third person views. When I went to the controls option I couldn't actually change anything. In fact, I couldn't see the key binds, just the note about the esc and backspace keys. I tried it with a fresh install of Garry's Mod, but had the same problem, so it's not conflicting addons. Any idea of what's causing this?
  • [QUOTE=Matsilagi;35432714]Downloaded the full pack without errors. I will upload it on my Dropbox.[/QUOTE] please do :)
  • Avatar of Sakarias88
  • [QUOTE=ProfessorZ;35432837]I can't seem to switch from first to third person views. When I went to the controls option I couldn't actually change anything. In fact, I couldn't see the key binds, just the note about the esc and backspace keys. I tried it with a fresh install of Garry's Mod, but had the same problem, so it's not conflicting addons. Any idea of what's causing this?[/QUOTE] That's weird. I tried it with a clean installation of GMod. Got Slim, Basic and Extra installed. No problems at all. The problem might be that you're using a MAC. I don't have a MAC myself so I haven't been able to test anything on MAC. Maybe you and I could do some testing one day and iron out the bugs for MAC?
  • Avatar of tigercat2000
  • so that garage in this video: [url]http://www.youtube.com/watch?v=P38d7yB_4No[/url] doesnt exist or what?
  • Actually, that sounds like a great idea. I do have a iMac, and would love to help squash some bugs. Just tell me what I can do. Pics maybe?
  • Avatar of Afromana
  • This addon is really easy to make cars for due to the already set up templates and documenatition. I'm not that good at LUA scripting, and I made a fully functional Mass Effect Truck Thing after one hour of trial and error [t]http://cloud.steampowered.com/ugc/576700870322347727/6AE26BF683C1EBC16AF9C372086B90D04099E8D9/[/t] Really well done, I imagine I'll be using this addon in the future.
  • Avatar of KingNick220
  • When I spawn the tank, I get this. 3rd person also doesn't work for any vehicle. [IMG]http://cloud.steampowered.com/ugc/594715184641978874/F54E3B2ADCAFE5500CD2693D995C365518EEB716/[/IMG]
  • Avatar of Tristan885
  • For me, all works fine :) When I tried the radio stations, I landed on oldies, it was playing Rick Astley - Never Gonna Give You Up *I felt rick rolled* but I enjoyed it. I tried race system, it was fun making my own race track in some maps. For AI, it was funny messing around with cars with that, the wander AI made me laugh when seeing cars randomly goes hit walls, a time, they went in fire and explode, then tried the other stuff... This addon amazed me with all these features.
  • Avatar of Sodisna
  • [QUOTE=Sakarias88;35432990]That's weird. I tried it with a clean installation of GMod. Got Slim, Basic and Extra installed. No problems at all. The problem might be that you're using a MAC. I don't have a MAC myself so I haven't been able to test anything on MAC. Maybe you and I could do some testing one day and iron out the bugs for MAC?[/QUOTE] That Third person view with seems to happy even without Scars.
  • Avatar of superstepa
  • Works almost perfectly in Gmod 13 apart from AI (doesnt even let to click the car) and the view change (doesnt do anything) Good job as always
  • Avatar of Afromana
  • So, I'm attempting to create an [url=http://i46.photobucket.com/albums/f116/cireking213/Oblivion/ME2-1/MassEffect22010-01-2820-53-54-62.jpg]Mass Effect hover car[/url] by editing the delorean, and for a while it worked perfectly. But after probably a bit too extensive editing, it appears to have dissapeared from the spawn menu, and [url=http://cloud.steampowered.com/ugc/576700870323973670/9F43642BA225F385220DB50CC62331BDA122BAE5/]refuses to re-appear.[/url] I've tried to rename it, change everything, change nothing, nothing seems to work. But the entity itself exsists, as I can "ent_create" it, whereas it spams: [code][addons\scars slim\lua\entities\sent_sakarias_scar_base\cl_init.lua:204] attempt to call method 'IsPlaying' (a nil value)[/code] Anyone have any idea what causes this? [editline]atw[/editline] Nevermind, I seem to have gotten it to work again, somehow. [editline]5th April 2012[/editline] Say, I wish to move the stabilizer in the Delorean script, but I have no idea how. What here do I need to change to be able to set its X axis? [code]self.StabilizerPropFly = ents.Create( "prop_physics" ) self.StabilizerPropFly:SetModel("models/props_junk/sawblade001a.mdl") self.StabilizerPropFly:SetPos(self.Entity:GetPos() + self.StabiliserOffset.x * self.Entity:GetForward() + self.StabiliserOffset.y * self.Entity:GetRight() + self.StabiliserOffset.z * self.Entity:GetUp() ) self.StabilizerPropFly:SetOwner(self.Owner) self.StabilizerPropFly:SetAngles(self.Entity:GetAngles()) self.StabilizerPropFly:SetColor(Color(255,255,255,0)) self.StabilizerPropFly:SetNoDraw( true ) self.StabilizerPropFly:Spawn() self.StabilizerPropFly:GetPhysicsObject():EnableGravity(false) self.StabilizerPropFly:SetCollisionGroup( GROUP_DEBRIS ) self.StabilizerPropFly:GetPhysicsObject():SetMass(self.StabilisationMultiplier) self.StabilizerPropFly:SetNotSolid( true ) self.StabilizerPropFly:GetPhysicsObject():EnableDrag(false) constraint.Weld( self.Entity, self.StabilizerPropFly, 0, 0, 0, true )[/code] The model I've set is too long, and therefore tips forward as the stabilizer is put at the wrong place.
  • Avatar of Mr.Flappy Jaw
  • [QUOTE=tigercat2000;35433015]so that garage in this video: [url]http://www.youtube.com/watch?v=P38d7yB_4No[/url] doesnt exist or what?[/QUOTE] I've been wondering the same thing. that was one of the main things that made me almost shit myself when I saw SCars 2.0 was released. Great mod nonetheless though.
  • Avatar of neter
  • Woohoo!! :)) I thought that it was still before the summer will be developed
  • Avatar of neter
  • Instead of icons Car icons are displayed questions [URL=http://radikal.ru/F/s57.radikal.ru/i158/1204/8d/7ad4c5f28632.png.html][IMG]http://s57.radikal.ru/i158/1204/8d/7ad4c5f28632t.jpg[/IMG][/URL] [editline]5th April 2012[/editline] and how to use this: [url]http://www.youtube.com/watch?feature=player_embedded&v=-YZ2E6HJpQk[/url]
  • Avatar of alexojm
  • It all works fine for me and I love it I am going to have some fun with this. My only question is that some have been asking what ever happened to the garage has the plan been scraped or is it just delayed because of problems ?
  • Avatar of Sakarias88
  • So some people are experiencing crashes when a car spawns. I'm not sure why. Would like to get some more information about this. This happens on both x64 and x86. Got a crash dump from Jarrod which didn't tell me that much more than he tried to spawn the Seat car. If the script fails it should print out a runtime lua error but instead it just crashes for some reason. [QUOTE=KingNick220;35434019]When I spawn the tank, I get this. 3rd person also doesn't work for any vehicle. [IMG]http://cloud.steampowered.com/ugc/594715184641978874/F54E3B2ADCAFE5500CD2693D995C365518EEB716/[/IMG][/QUOTE] For people with camera issues. This is a common addon conflict. It appears when another addon isn't hooking the calc view hook properly so it overrides all other hooks other addons have added. [QUOTE=afromana;35435383] Say, I wish to move the stabilizer in the Delorean script, but I have no idea how. What here do I need to change to be able to set its X axis? The model I've set is too long, and therefore tips forward as the stabilizer is put at the wrong place.[/QUOTE] You just change the StabiliserOffset variable. [QUOTE=neter;35439566]Instead of icons Car icons are displayed questions [URL=http://radikal.ru/F/s57.radikal.ru/i158/1204/8d/7ad4c5f28632.png.html][IMG]http://s57.radikal.ru/i158/1204/8d/7ad4c5f28632t.jpg[/IMG][/URL] [editline]5th April 2012[/editline] and how to use this: [url]http://www.youtube.com/watch?feature=player_embedded&v=-YZ2E6HJpQk[/url][/QUOTE] To me it seems like MAC is having issues finding files which would explain both this problem and the keys problem. It works like this. The stool checks if a certain icon exists and if it doesn't it will replace it with a question mark icon. [QUOTE=LZJeffrey;35439808]How get into the Garage?[/QUOTE] I moved the garage out as a separate addon. I started concentrating on more important stuff for SCars since the garage isn't really giving anything more than a nice interface. I'm still planning on releasing it. It's just that it will need a lot more polishing.
  • Avatar of residualgrub
  • [QUOTE=Sakarias88;35440325] I moved the garage out as a separate addon. I started concentrating on more important stuff for SCars since the garage isn't really giving anything more than a nice interface. I'm still planning on releasing it. It's just that it will need a lot more polishing.[/QUOTE] not to be a pest and take your time but will the editor in your "Making a warthog in the new editor" video be released.
  • Avatar of Sakarias88
  • [QUOTE=residualgrub;35440395]not to be a pest and take your time but will the editor in your "Making a warthog in the new editor" video be released.[/QUOTE] It is released already. It's included in the Slim version (which you need). The warthog models are also included if you would like to make a halo warthog in the editor. Just go to "steamapps\sakariasjohansson\garrysmod\garrysmod\addons\SCars Slim\Developer Tutorials\Create a car\Instructions.txt" for more instructions.
  • Avatar of residualgrub
  • [QUOTE=Sakarias88;35440428]It is released already. It's included in the Slim version (which you need). The warthog models are also included if you would like to make a halo warthog in the editor. Just go to "steamapps\sakariasjohansson\garrysmod\garrysmod\addons\SCars Slim\Developer Tutorials\Create a car\Instructions.txt" for more instructions.[/QUOTE] ok ty for your time did not notice that
  • Avatar of neter
  • [QUOTE=Sakarias88;35440325]To me it seems like MAC is having issues finding files which would explain both this problem and the keys problem. It works like this. The stool checks if a certain icon exists and if it doesn't it will replace it with a question mark icon.[/QUOTE] how can i manually add the icons there?