• WolfDJ 4.0 - In-Game MP3 Streaming
    436 replies, posted
  • Does this have to be used with a webserver? I just want to play music for myself in game without having to alt-tab.
  • Avatar of wauterboi
  • [QUOTE=caekdaemon;33783789]Does this have to be used with a webserver? I just want to play music for myself in game without having to alt-tab.[/QUOTE] You have to be in the server and you have to have the music on that same server.
  • [QUOTE=wauterboi;33787830]You have to be in the server and you have to have the music on that same server.[/QUOTE] But I just want a decent music player to use on singleplayer. I'm currently using FuriousMP3 and it does not go to the next track automatically.
  • Avatar of Juze
  • I'm getting tons of errors on Apache server (Ubuntu 10.04) with all directories chmodded to 755 recursively. Such as this one: [CODE]PHP Warning in /var/www/wolfdj4/verification.php on line 29: readdir() expects parameter 1 to be resource, boolean given Stack trace: #0 /var/www/wolfdj4/verification.php(29): readdir(boolean)[/CODE] WolfDJ4, fresh install. I don't have my server up btw. And there are no CSS/JS elements. SQLite won't even work at all, I'm using MySQL anyway.
  • Avatar of Juze
  • [QUOTE=Banana Lord.;33934654]Did you chmod things as instructed..?[/QUOTE] They were already chmod 755 as I uploaded them on the server. Since that didn't work, I chmodded them all. /var/www/ is chown root, but the whole wolfdj4 folder should be chown juze recursively. [url]http://i.imgur.com/iSu5Z.png[/url] PS: Attempting to browse to the upload page crashes Firefox.
  • if you are running on ubuntu then chmod the things to 777, try that and report back
  • Avatar of Juze
  • [QUOTE=camcole1;33934744]if you are running on ubuntu then chmod the things to 777, try that and report back[/QUOTE] Works now. Weird. o_O [QUOTE=Banana Lord.;33934772]chmod and chown are different[/QUOTE] I'm not dumb. EDIT: Upload page still crashes my Firefox though. EDIT2: My Account page now shows this: [CODE]Unknown Error(8192): Comments starting with '#' are deprecated in /etc/php5/apache2/conf.d/mcrypt.ini on line 1 in Unknown on line 0[/CODE] EDIT3: IE won't crash. Except there's no Java applet there. Bah, reinstalling Java. [editline]28th December 2011[/editline] Okay, that won't work, any ideas?
  • Avatar of lorde banana
  • it's not weird, it says in the first post to chmod the folders. you said you chown'd the files, which doesn't matter as long as your webserver has permission to run the scripts
  • Avatar of Juze
  • [QUOTE=Banana Lord.;33934957]it's not weird, it says in the first post to chmod the folders. you said you chown'd the files, which doesn't matter as long as your webserver has permission to run the scripts[/QUOTE] Read my post carefully. They are both chown'd and chmod'd respectively. I am not running anything as root, I only used sudo to do chmod and chown so I'd have permissions for the files. The requirement was to chmod 777 them, not chmod 755 like described. Now, any luck with this Java problem? Chrome and IE fail with it too. Java 6U29 in browser and this: [CODE]C:\Users\Juze>java -version java version "1.7.0" Java(TM) SE Runtime Environment (build 1.7.0-b147) Java HotSpot(TM) 64-Bit Server VM (build 21.0-b17, mixed mode)[/CODE] EDIT: Heck, just nevermind, it works for others.
  • [code]PHP Notice in C:\xampp\htdocs\wolfdj\verification.php on line 67: Undefined index: playtime_string Stack trace:[/code] It is a valid MP3, it plays fine on my computer, but when I click it, it doesn't let me verify or add the song.
  • Avatar of Techbot
  • don't hit me but I get this [code] Uncaught Exception in /home/techbot/public_html/dj/lib/modules/dbc_engines/sqlite.php:18 Failed to connect to database: unable to open database: /home/techbot/public_html/dj/db/wolfdj.db Stack trace: #0 /home/techbot/public_html/dj/lib/classes/dbc.php(40): kernel_dbc_sqlite->__construct(array) #1 /home/techbot/public_html/dj/lib/classes/kernel.php(48): kernel_dbc->__construct() #2 /home/techbot/public_html/dj/lib/init.php(58): kernel->load_classes(string, string) #3 /home/techbot/public_html/dj/index.php(20): require_once(string) #4 {main} [/code] [editline]16th January 2012[/editline] and yes all folders have 755 permissions
  • I get the error [QUOTE]PHP Unknown Error in /home/******/public_html/music/lib/getid3/getid3.php on line 63: Function eregi() is deprecated Stack trace: #0 /home/*******/public_html/music/lib/getid3/getid3.php(63): eregi() #1 /home/******/public_html/music/verification.php(54): getID3->getID3()[/QUOTE]
  • Avatar of lorde banana
  • not an error [editline]22nd January 2012[/editline] it's a warning, you can use [url]http://php.net/manual/en/function.error-reporting.php[/url] to shut it up (even though it should be fixed)
  • Avatar of Techbot
  • it works now... sort of. [t]http://i.imgur.com/LuyCX.png[/t] uploading works, verification doesn't I get this error: [img]http://i.imgur.com/9Kh3m.png[/img] sorry for the bump [editline]6th February 2012[/editline] looks like it's getid3's fault.
  • Avatar of Techbot
  • it works sometimes, sometimes it doesn't [editline]6th February 2012[/editline] meant to merge that sorry
  • Avatar of ben818
  • Hello, Okay, I need some help here. When I have to edit the config file, and replace [url]http://release.wolfcode.net/projects/wolfdj4/songlist.php[/url] and [url]http://release.wolfcode.net/projects/wolfdj4/song.php[/url] What do I put here? Where do I get them from? Any help is appreciated! Thanks!
  • I have an error when I process the songs I've uploaded. [code] PHP Unknown Error in /var/www/www/wolfdj/lib/getid3/getid3.php on line 63: Function eregi() is deprecated Stack trace: #0 /var/www/www/wolfdj/lib/getid3/getid3.php(63): eregi() #1 /var/www/www/wolfdj/verification.php(54): getID3->getID3() [/code] Anyone have any ideas? I'm using MySQL btw.
  • [QUOTE=Banana Lord.;34761037]That's a warning, and you can disable it with a PHP function. I think it's error_reporting[/QUOTE] Err, I sorta gave up in the end.. It all went wrong I have no idea why as I definitely installed and configured it correctly. The images on the webpage wern't showing up it was all just a white page, different errors everytime I uploaded a song and in the end the in-game addon seemed to be completely broken.. Oh well.
  • Avatar of jmazouri
  • If anyone's having issues with the id3 libraries just update them to the latest versions ([url]http://getid3.sourceforge.net/[/url]).
  • Avatar of lorde banana
  • [QUOTE=TGiFallen;34780692]I'm having problems where it's crashing a lot of people when they join.[/QUOTE] yeah that's probably due to the HTML panel, for some reason the game just absolutely hates doing HTML/HTTP stuff when they first join
  • Avatar of TGiFallen
  • [QUOTE=Banana Lord.;34781040]yeah that's probably due to the HTML panel, for some reason the game just absolutely hates doing HTML/HTTP stuff when they first join[/QUOTE] Is there any way I should go about fixing this?
  • Avatar of lorde banana
  • [QUOTE=TGiFallen;34782314]Is there any way I should go about fixing this?[/QUOTE] the only way I could think of fixing this would be to do objPl:ConCommand( "wolfdj_starthtml" ); or something in PlayerInitialSpawn (when you do ConCommand it delays it until their entity exists clientside, I use this to delay the loading of ranks/stats on my server). That still might be too early too, but you could give it a shot
  • Avatar of ben818
  • [QUOTE=ben818;34627761]Hello, Okay, I need some help here. When I have to edit the config file, and replace [url]http://release.wolfcode.net/projects/wolfdj4/songlist.php[/url] and [url]http://release.wolfcode.net/projects/wolfdj4/song.php[/url] What do I put here? Where do I get them from? Any help is appreciated! Thanks![/QUOTE] [QUOTE=Techbot;34712273]uhh the url of your webspace?[/QUOTE] That doesn't really help me...