• WolfDJ 4.0 - In-Game MP3 Streaming
    436 replies, posted
  • [QUOTE=camcole1;32066979]I am using mysql and no images are loading. the css is messed up[/QUOTE] Talked about this on steam, and his host doesn't allow the AddType directive. Delete the .htaccess file in /css/ and the problem is fixed. This kills styles on IE9 though. [editline]1st September 2011[/editline] [QUOTE=Banana Lord.;32067311]You made a wonderful addon <3 :buddy:[/QUOTE] Thank You.
  • Hi while I am here can you add a pubic uploader (toggleable by setting?) that allows viewers to upload MP3s that need to be verified by an admin? [editline]1st September 2011[/editline] And like, it logs + displays their IP in the pending page. That would be so amazing, I really don't want to make another =(
  • Can you tell us what files are updated in your updates? I have customized settings
  • [QUOTE=camcole1;32067768]Can you tell us what files are updated in your updates? I have customized settings[/QUOTE] Can you use the SVN archive? That's one of the main reasons I use SVN. You can see exactly what I changed, and what I said I changed for each revision since I originally put it up.
  • Uncaught Exception in /home/coloredm/public_html/gmodmusic/lib/modules/dbc_engines/mysql.php:44 Duplicate entry '0' for key 'PRIMARY' Stack trace: #0 /home/coloredm/public_html/gmodmusic/lib/classes/dbc.php(51): kernel_dbc_mysql->query(string, string, string, string, string, string, string, string) #1 /home/coloredm/public_html/gmodmusic/process.php(65): kernel_dbc->__call(array, array) #2 /home/coloredm/public_html/gmodmusic/process.php(65): kernel_dbc->query(string, array) #3 {main}
  • Can you include a little context when you post error please? That tells me you tired to insert a song with an ID of 0 twice. Don't do that....
  • i am trying to upload songs the title is Call It What You Want by Foster The People and in the verification i click the button. and the error comes up
  • [QUOTE=camcole1;32067988]i am trying to upload songs the title is Call It What You Want by Foster The People and in the verification i click the button. and the error comes up[/QUOTE] You're using MySQL and I forgot an AUTOINCREMENT since sqlite doesn't need it. Grab the latest lib/modules/dbc_engines/mysql.php and reinstall, or add an autoincrement option to the ID field in wolfdj_songs. [editline]1st September 2011[/editline] Derp, forgot an underscore. Fixed. [editline]1st September 2011[/editline] Fixed an error with the MySQL and SQLite escaping that died on question marks, and modified the file listing to only load the flash player when you click Play Sample. The page lagged a LOT with over 600 flash players -.- If you're not using Revision 10, you should update to the latest revision.
  • [QUOTE=mr.wolf;32067588]I'll work on it tomorrow.[/QUOTE] holy shit do you want to be my wife or something
  • [QUOTE=Banana Lord.;32068781]holy shit do you want to be my wife or something[/QUOTE] I'm flattered, but taken. [editline]1st September 2011[/editline] If you REALLY want to, you can donate to my clan. Link's in the my title. [editline]1st September 2011[/editline] But don't feel obliged.
  • Whenever I search for something in WolfDJ it does not show results, only shows how many at top
  • Thanks for all the help earlier via Steam with the web side of things. Now ingame though, users are reporting this to me: Hook 'WolfDJKeyListener' Failed: [wolfdj\cl_init.lua:37] attempt to index field 'Menu' (a nil value)
  • [QUOTE=jimbodude;32069612]Thanks for all the help earlier via Steam with the web side of things. Now ingame though, users are reporting this to me: Hook 'WolfDJKeyListener' Failed: [wolfdj\cl_init.lua:37] attempt to index field 'Menu' (a nil value)[/QUOTE] I know you want wolfs help but try redownloading that file. Wolf did update the svn a few times in the past hour. line 37 says for me atleast [QUOTE]self.Menu:SetVisible( true )[/QUOTE] So hope i help a little if not then sorry for wasting your time :quagmire: [editline]1st September 2011[/editline] on a side note who thinks they should change [QUOTE]: quagmire :[/QUOTE] to [QUOTE]:giggity:[/QUOTE] would make more sense
  • [QUOTE=camcole1;32069430]Whenever I search for something in WolfDJ it does not show results, only shows how many at top[/QUOTE] Link me your songlist.php URL
  • [url]http://gmodmusic.theminiserver.com/[/url] [editline]1st September 2011[/editline] and total songs available stays at 7 when searching no matter what you type
  • Commited revision 12: [quote]Changed the delimiter to a pipe instead of a tab, since the tab doesn't seem to work on some servers. Bulletproofed the menu code against non-initialization.[/quote] Should fix both your problems.
  • When adding to queue: Hook 'WolfDJDrawBar' Failed: [wolfdj\cl_init.lua:605] attempt to perform arithmetic on field 'Mid' (a nil value) When a user tries to nominate a song: @lua\includes\extensions\string.lua:57] bad argument #1 to 'concat' (table expected, got nil) And also, when selecting music, console spams: AudioPlayer is not defined - :0Browser Message: Uncaught ReferenceError: AudioPlayer is not defined - :0Browser Message: Uncaught ReferenceError: AudioPlayer is not defined - :0Browser Message: Uncaught ReferenceError: AudioPlayer is not defined But it does still work.
  • I think I see the issue with nominating: local songInfo = string.Explode( "\t", args[1] ) \t is no longer used as the delimiter, so replace that with "|", or use the config variable WolfDJ.Delimiter. EDIT: or not. It appears as if WolfDJ.Menu.SongList.SongData[ ID ] is nil. [editline]2nd September 2011[/editline] About the web interface: When processing songs, if I leave genre as Unkown, it adds to the mysql db just fine, and is moved, deleted, etc all fine, however, if I select any genre, it claims to have completed successfully, no errors, but it isn't moved, or added to the db.
  • Songlist.php has a slight syntax error when searching: Line 34, replace with: $strSQL = "SELECT * FROM `wolfdj_songs` WHERE `title` LIKE '%?%' OR `artist` LIKE '%?%' OR `genre` LIKE '%?%' ORDER BY `artist` ASC, `title` ASC"; That should fix the search issue. EDIT: Automerge broke :(
  • Sorry, looks like I forgot a few variables when I did that replace last night. I've been at work all day today and haven't been able to work on it at all. I'll fix stuff when I get home in about an hour or so. Sorry guys!
  • Since a lot of people are awaiting an update, I'll upload my fixed versions for you. I hope this is okay mr.wolf, but if not, let me know and I'll take it down asap. Everything here should work fine (except genres. I'm still having an issue with any other genre except unknown, so when uploading, just leave genre set as unknown). Do remember to change all the config vars in config.lua, and the config files on the web code. -snipped link- :)
  • Hey guys, sorry for the wait. I came down with some sort of sickness yesterday and have been feeling nauseousness with a fever all day. Feeling better now though, so I'm going to try and get everything working =)
  • [QUOTE=mr.wolf;32100525]Hey guys, sorry for the wait. I came down with some sort of sickness yesterday and have been feeling nauseousness with a fever all day. Feeling better now though, so I'm going to try and get everything working =)[/QUOTE] yay!!!! Are you gonna add a genre mysql? [editline]3rd September 2011[/editline] Can you add me i want to ask you if a feature can be added and i have a server with the example