• gmsv_gatekeeper - Lua controlled server authentication
    453 replies, posted
  • [QUOTE=BlackAwps;35630991]No Linux love?[/QUOTE] Linux survived the update because it doesn't use signature scanning.
  • Avatar of lorde banana
  • [QUOTE=BlackAwps;35630991]No Linux love?[/QUOTE] as chris said, it never broke, did you read the press release?
  • I figured something was still broken because one of my servers was crashing after I updated it.. Turns out it was something else.
  • Avatar of TheJjokerR
  • There already has been an update for it, the revision was made on the 18th according to the google code. Just get it of the svn.
  • Oh, just had exactly same size as before so I didn't think it was a new one ;) thanks.
  • Avatar of Drakehawke
  • [code]error loading module 'gatekeeper' from file '/home/darkrp/srcds/orangebox/garrysmod/lua/includes/modules/gmsv_gatekeeper_linux.dll': <TAB>/home/darkrp/srcds/orangebox/garrysmod/lua/includes/modules/gmsv_gatekeeper_linux.dll: invalid ELF header[/code] Edit: oops fixed, note to self never try and download things from the googlecode browse thing again -.-
  • Avatar of gamerpaddy
  • [CODE]02:26:18 Lua Error: [cpp] PlayerPasswordAuth hook must return a boolean, string, or table value![/CODE] :(( EDIT: oh oops.. its difficult to return yes or no out of a http callback to password auth... my bad sry
  • Getting this error when I try to load: [code] > require ( [[gatekeeper]] )... [@lua_run:1] loop or previous error loading module 'gatekeeper' [/code]Any idea? I'm using the latest build
  • Avatar of Phoenixf129
  • [QUOTE=Undefined;36480094]Getting this error when I try to load: [code] > require ( [[gatekeeper]] )... [@lua_run:1] loop or previous error loading module 'gatekeeper' [/code]Any idea? I'm using the latest build[/QUOTE] You're not using the latest build Shane. (Download it again)
  • Avatar of Drew P. Richard
  • The new Source update that just dropped is giving me SteamID Invalid errors again, can we get a fix sometime soon?
  • Same, I did do an SVN update, didn't work. Would some nice soul please update? thanks, luv u bai!
  • Avatar of AzuiSleet
  • Until somebody updates it, just set: [code] gk_force_protocol_enable 1 gk_force_protocol 21 [/code]
  • [QUOTE=AzuiSleet;36545728]Until somebody updates it, just set: [code] gk_force_protocol_enable 1 gk_force_protocol 21 [/code][/QUOTE] Thanks, works for now :)
  • Avatar of nexbr
  • It's not working anymore, are not kicking players anymore with the Hook
  • Avatar of Aide
  • When ever trying to require gatekeeper I get 'CBaseServer signature failed!'. Module is up to date it fails to load with no existing gatekeeper convars visible. Apparently others are also having trouble with 'GetByIP' and 'Drop'.
  • Avatar of I am God.
  • I fixed it up for gmod13, I thought you guys might wanna use it too: [url]www.twoscore.net/gmsv_gatekeeper.zip[/url]
  • Avatar of Python1320
  • Here you go: [URL="http://g3.iriz.uk.to/~srcds/modules/gm13/bin/"]http://g3.iriz.uk.to/~srcds/modules/gm13/bin/[/URL]
  • Avatar of Teddi
  • -Snip- Nevermind. Turns out the latest revision is for GM13. For anyone that wants the latest (and probably final) version for GM12, use revision 202 of the SVN ([URL=http://code.google.com/p/gmodmodules/source/detail?r=202]as documented here[/url])
  • Avatar of lorde banana
  • Using revision 202 or 203 both cause my GMod 12 server to crash when calling gatekeeper.GetPlayerByAddress. OS is Linux. I also believe it crashes when calling gatekeeper.Drop, and gatekeeper.DropAllPlayers doesn't work (nothing happens)
  • Avatar of andre_bule
  • [QUOTE=Jocken300;37932747]GMod 13 crashes whenever I try to use the latest revision.[/QUOTE] Meaning that "Gatekeeper" is brukin bai
  • Avatar of Jocken300
  • [QUOTE=andre_bule;37932917]Meaning that "Gatekeeper" is brukin bai[/QUOTE] I just figured I'd report the issue, so that the module could get fixed?
  • Avatar of Chewgum
  • Blackawps gatekeeper works for gm13: [URL]http://blackawps-glua-modules.googlecode.com/svn/trunk/gmsv_gatekeeper[/URL] linux: [URL]http://g3.iriz.uk.to/~srcds/modules/gm13/bin/[/URL]
  • Avatar of Jocken300
  • [QUOTE=_Chewgum;37933836]Blackawps gatekeeper works for gm13: [URL]http://blackawps-glua-modules.googlecode.com/svn/trunk/gmsv_gatekeeper[/URL] linux: [URL]http://g3.iriz.uk.to/~srcds/modules/gm13/bin/[/URL][/QUOTE] Thanks.
  • Avatar of lorde banana
  • For anyone looking for a working GMod 12 version, [url]https://dl.dropbox.com/u/5648925/gmod/gmsv_gatekeeper_linux_gmod12.zip[/url] credits to [i]Drakehawke[/i]
  • Avatar of Python1320
  • [url]http://g.iriz.uk.to/~srcds/modules/gm13/bin/[/url] [editline]19th October 2012[/editline] Seems to work for me [editline]19th October 2012[/editline] At least the hook part does