• gm_mount2 - Use any source-engine content in GMod
    1,320 replies, posted
  • [QUOTE=xlSomeGuylx;22132881]I can't seem to get Dystopia to mount. I tried both reinstalling the mod and mount itself, but I can't get it to become available. Dystopia is the only mod that I have that's doing this, all the others I have (Such as Dark Messiah, Age of Chivalry, NeoTokyo, Fortress Forever, ect.) mount and run just fine (And yes, I have ran Dystopia at least once)[/QUOTE] Same here it used to work but recently Dystopia and D.I.P.R.I.P refuse to mount they're just shaded out and yes I started the games blah blah reinstalled all those things. Simply they used to work, now they don't.
  • [QUOTE=morphhh;22127211]Still with this problem... ^:suicide:[/QUOTE] I need more information: [list] [*]Hardware Specs [*]DirectX Mode [*]Used version of gm_mount2 [*]Is really everything installed correctly? ([U]Addons/Left 4 Dead[/U] and [U]Addons/Left 4 Dead 2[/U] [b]must[/b] be present). [*]Tried gm_mount without any other addons installed (but the one of gm_mount2)? [*]Tried on clean gmod? [/list] [editline]09:20AM[/editline] [QUOTE=Dave The Ninja;22135450]Same here it used to work but recently Dystopia and D.I.P.R.I.P refuse to mount they're just shaded out and yes I started the games blah blah reinstalled all those things. Simply they used to work, now they don't.[/QUOTE] I can't understand, why this happens to you. I just had this one time because steam somehow has "uninstalled" my game (doh). So I just had to start it one more time and it was present and selectable in the menu again.
  • Sorry if im late, Im unsure if this is EVEN POSSIBLE. But there IS errors when loading any l4d2-l4d maps. CModelLoader::Map_IsValid: Map 'maps/c1m3_mall.bsp' bsp version 21, expecting 20 Again, sorry if im late, Just wondering if this is possible to be fixed :P
  • [quote=Readme.txt]#WARNING Left 4 Dead and Left 4 Dead 2 maps are NOT COMPATIBLE with GMod. They WILL crash your game once you try loading them.[/quote] qft
  • [QUOTE=aVoN;22146523]qft[/QUOTE] BLAH!, Rate me late :P *rates self late*
  • [QUOTE=morten8035;22149212]Is L4D1 required to get eyes for L4D2 working?[/QUOTE] Considering I have both games and have the same issue still, I doubt it.
  • Huh, I can't mount L4D2. I can mount everything else just fine, but when I try to mount L4D2, I crash. I've tried unticking a bunch of game mounts as well as using a fresh Gmod folder, none of which worked. Is there anything else I can try? :gonk:
  • [QUOTE=morten8035;22149212]Is L4D1 required to get eyes for L4D2 working?[/QUOTE] Not to my knowledge. Post a condump on pastebin please, because it seems like there are textures missing. I'd like to add them/fix it. But since I don't have this issue, I can't fix it so I need you. [editline]08:00AM[/editline] [QUOTE=Lite :3;22158056]Huh, I can't mount L4D2. I can mount everything else just fine, but when I try to mount L4D2, I crash. I've tried unticking a bunch of game mounts as well as using a fresh Gmod folder, none of which worked. Is there anything else I can try? :gonk:[/QUOTE] Start L4D2, make it update, check for integrity - Like Readme.txt tells you. Try again. Also: Supply the crashmessage (open it and post the info on "extended")
  • [QUOTE=aVoN;22159655]Not to my knowledge. Post a condump on pastebin please, because it seems like there are textures missing. I'd like to add them/fix it. But since I don't have this issue, I can't fix it so I need you. [/QUOTE] Did it a [url=http://www.facepunch.com/showpost.php?p=22122493&postcount=507]few posts[/url] ago :)
  • [QUOTE=morten8035;22160759]Did it a [url=http://www.facepunch.com/showpost.php?p=22122493&postcount=507]few posts[/url] ago :)[/QUOTE] Ok. Can you please download GCFScape and open the files steamapps/common/left 4 dead 2/left4dead2/pak01_dir.vpk and pak02_dir.vpk. Check both for the folder "models/survivors/gambler/" and tell me, in which one it is. For me, it's in the pak01.
  • It's in pack01_dir. I assume you want the vmt? [URL="http://pastebin.com/NmpPxK0t"]gambler_eyeball_L[/URL] - gambler_eyeball_R are exactly like gambler_eyeball_L.
  • [QUOTE=aVoN;22159655]Not to my knowledge. Post a condump on pastebin please, because it seems like there are textures missing. I'd like to add them/fix it. But since I don't have this issue, I can't fix it so I need you. [editline]08:00AM[/editline] Start L4D2, make it update, check for integrity - Like Readme.txt tells you. Try again. Also: Supply the crashmessage (open it and post the info on "extended")[/QUOTE] I'm guessing you want the crash logs? I'll just leave these here - [url]http://www.mediafire.com/?zzinrmmmzml[/url] Also, tried verifying, making L4D2 update, etc. Still no progress. Edit: Good news, a clean reinstall of Gmod + L4D2 fixed it. :smug: Sorry for the trouble.
  • [QUOTE=morten8035;22164468]It's in pack01_dir. I assume you want the vmt? [URL="http://pastebin.com/NmpPxK0t"]gambler_eyeball_L[/URL] - gambler_eyeball_R are exactly like gambler_eyeball_L.[/QUOTE] No, I just needed to know if it's in 01, because I only mount 01. Can you look at your Graphic-Settings/Shader Quality. Or better: Print a screenshot of your Graphic Settings screens.
  • Can you switch everything to High/Ultra High and enable DirextX 9 please? Use -dxlevel 90.
  • Well. The game crashed when i sett anti aliasing on more than 8x CSAA, So I stick to 8x CSAA as the "highest" setting. And It looks like the game crashes when sync is on. Odd, I can swear I have had all settings on max before. (Because of -dxlevel 90 maybe?) Here is a [URL="http://i49.tinypic.com/33krm05.jpg"]screenshot[/URL] of the settings. Ever odder, I can run the game without lag with these setting :D And it looks like the survivors have got their [URL="http://i46.tinypic.com/vowubt.jpg"]eyes[/URL] back :D The annoying this is that every time I start gmod with -dxlevel 90, all settings it reseted, So I guess I need to make a config for that? :( Thanks anyway almighty aVoN McKay. :)
  • Ok, so the solution for the eyes is really running on DirextX 9.0 how it seems.
  • Yeah. I also got dynamic light/shadows back too ♥. Every time I change a setting, gmod crashes. I tried to google to find some answers to that without success.
  • Dxlevel should be 95 or 98, not 90, unless you have a REALLY low-end DX9 card, and even [I]then[/I] you should at least [I]try[/I] setting it to 95.
  • Well, I have NVIDIA GeForce 8600M GT. I will try out 95 instead of 90 later :) EDIT: I still crashes with 95 and 98.
  • Hey, I know this is pretty much dead by now, but Garry changed the extensions thing, so now the gmount thing doesn't work...can you fix it plz?
  • [QUOTE=raubana;22212907]Hey, I know this is pretty much dead by now, but Garry changed the extensions thing, so now the gmount thing doesn't work...can you fix it plz?[/QUOTE] GM_Mount2 still works. It's not under "GMod Settings" anymore, it's now under "Extensions/Games".
  • [QUOTE=Omolong;20285881]I fixed 2 things for you aVoN. The problem for why it wasn't loading was the module. It was in lua/[b]include[/B]/modules, when it should have been in lua/[B]includes[/B]/modules. Also, I noticed you missed out quite a few source mods that are on Steam, so I have edited one of the .luas to fix it. Here is the chunk that I edited: [lua]-- Currently copy & paste from the old enhanced-gm_mount by SteveUk. later my addon will find all your games dynamically local AdditionalContent = { ageofchivalry = {title = "Age of Chivalry",depotid = 17510}, mm = {title = "Dark Messiah",depotid = {2100,2130}}, diprip = {title = "D.I.P.R.I.P. Warm Up",depotid = 17530}, dystopia = {title = "Dystopia",depotid = 17580}, esmod = {title = "Eternal Silence",depotid = 17550}, insurgency = {title = "Insurgency Modern Infantry Combat",depotid = 17700}, left4dead = {title = "Left 4 Dead",depotid = 500,vpk = "pak01_dir.vpk"}, left4dead2 = {title = "Left 4 Dead 2",depotid = 550,vpk = "pak01_dir.vpk"}, pvkii = {title = "Pirates, Vikings, and Knights II",depotid = 17570}, se1 = {title = "SiN Episodes",depotid = 1300}, smashball = {title = "Smashball",depotid = 17730}, synergy = {title = "Synergy",depotid = 17520}, ship = {title = "The Ship",depotid = 2400}, zps = {title = "Zombie Panic! Source",depotid = 17500}, }[/lua] That goes into mount2.lua, and I think you can tell where in it.[/QUOTE] What about Fortress Forever? [editline]08:30PM[/editline] [QUOTE=blackops7799;20290538]Oh snap. Didn't even notice that. Sweet. [B]Edit:[/B] Potential problem? [img]http://i50.tinypic.com/15yjk9t.png[/img][/QUOTE] i imagine if you were to check that box it would cause a time paradox
  • [QUOTE=SuperEmoBros;22219582]What about Fortress Forever? [editline]08:30PM[/editline] i imagine if you were to check that box it would cause a time paradox[/QUOTE] Why do you reply to things which are months old and got fixed ages ago? [list] [*]Fortress Forever is a sourcemod. Every sourcemod can be mounted. Just games sold on Steam must be present in that file (btw: That file does not exist anymore). [b]This has already been answered in this thread[/b]. Even the OP says that. [*]Mounting GMod in GMod got fixed ages ago. And not a "timeparadox". [b]Fucking dumb meme-reply[/b] [*][highlight]Why do I reply to a troll-post?[/highlight] [/list]
  • That reminds me aVoN, Dystopia doesn't seem to be mountable any more, and the Counter-Strike Beta isn't listed in the mount menu.
  • [QUOTE=Omolong;22220793]That reminds me aVoN, Dystopia doesn't seem to be mountable any more, and the Counter-Strike Beta isn't listed in the mount menu.[/QUOTE] CS:S Beta should be just "Counter-Strike". And Dystopia should be started at least once before you can mount it.
  • [QUOTE=aVoN;22222072]CS:S Beta should be just "Counter-Strike". And Dystopia should be started at least once before you can mount it.[/QUOTE] I have started Dystopia at least once. Still got the problem.
  • [QUOTE=Omolong;22229269]I have started Dystopia at least once. Still got the problem.[/QUOTE] Strange. I'll look further into it.
  • I have none at all. Every mod i have can be mounted with no problems at all.