• Environments
    446 replies, posted
  • Avatar of LemONPLaNE
  • [QUOTE=CmdrMatthew;29470383]Sure feel free to, just be sure to give credit. Just don't release a copy or anything, which I'm sure your not going to do. [editline]27th April 2011[/editline] Also, I will try to add a sound to the helmet. Do you mean like a hissing sound?[/QUOTE] Only when opening it, thankyouverymuch. When you close it, there should be a sucking sound, something like "tschp".
  • Avatar of blade32232
  • thx If you want I could try and get you a spot on the team but so far it's only me and the creator so yeah. A hissing sound would be good,
  • Avatar of CmdrMatthew
  • No thanks, I have my hands full with this add-on already. I am willing to help with issues or anything, so if you have any trouble, feel free to ask me. Might I ask what you are making? PS: I have a surprise waiting for revision 101 if all goes well or 111 if it doesn't.
  • Avatar of blade32232
  • well I'm working on a more advanced version of spacebuild it will be better and more like space survival then just building
  • Avatar of BackwardSpy
  • So, what do I need and what is compatible with this? I want to replace spacebuild somewhat, it's so laggy and unstable. From what I can gather, I can install this, LS3 (Is RD3 needed?) and SBEP and it'll all play nice together? [editline]1st May 2011[/editline] Also, my HUD is also squashed in the X direction (res: 1440x900). I understand you're working on fixing this though :)
  • Avatar of LemONPLaNE
  • [QUOTE=Chris220;29547384]So, what do I need and what is compatible with this? I want to replace spacebuild somewhat, it's so laggy and unstable. From what I can gather, I can install this, LS3 (Is RD3 needed?) and SBEP and it'll all play nice together? [editline]1st May 2011[/editline] Also, my HUD is also squashed in the X direction (res: 1440x900). I understand you're working on fixing this though :)[/QUOTE] You need to disable LS3 completely, and disable the lua folder in SB3. Do this by appending "_off" or something to the info file/the lua folder.
  • Avatar of BackwardSpy
  • Ok so I've entirely disabled LS3C and LS3E, and disabled the lua inside the SB3 folder. So that leaves RD3 completely enabled and CAF completely enabled. [editline]1st May 2011[/editline] Yep, that all worked. Thanks for your help!
  • [QUOTE=LemONPLaNE;29548080]You need to disable LS3 completely, and disable the lua folder in SB3. Do this by appending "_off" or something to the info file/the lua folder.[/QUOTE] i think im a complete moron but still dont understand wat is needed and how to disable what isnt needed anyone fancy explaining more dumbed down :D
  • Hey, any chance you could add support for 1360x768? I know it's a weird resolution, but...
  • Avatar of CmdrMatthew
  • [QUOTE=cadandra;29658425]wat aboutt he sb one?[/QUOTE] Just delete the lua folder of it. [editline]6th May 2011[/editline] [QUOTE=tman0;29658416]Hey, any chance you could add support for 1360x768? I know it's a weird resolution, but...[/QUOTE] I can try to, I don't have that resolution, might be able to force it.
  • Avatar of CmdrMatthew
  • [QUOTE=cadandra;29658726]i delete the ls3 lua folder and now i get This Stool is not active[/QUOTE] Do you have any errors? and what were the folders in that lua folder?
  • [QUOTE=CmdrMatthew;29658912]Do you have any errors? and what were the folders in that lua folder?[/QUOTE] im confused what do you mean by the ls3 core lua folder?
  • Avatar of CmdrMatthew
  • [QUOTE=cadandra;29658942]im confused what do you mean by the ls3 core lua folder?[/QUOTE] its the addon for LS3 that doesnt contain any models or materials, just lua.
  • Okay i have 5 folders Custom Addon Framework LS3 - with folders LUA DATA and inside lua is CAF and entities LS3Entities - With all the materials models SB3 - with all the materials and models maps etc enviroment - etc when i delete the sb3 lua folder and the ls3 folder i get the stole not active error
  • Avatar of CmdrMatthew
  • [QUOTE=cadandra;29659221]Okay i have 5 folders Custom Addon Framework LS3 - with folders LUA DATA and inside lua is CAF and entities LS3Entities - With all the materials models SB3 - with all the materials and models maps etc enviroment - etc when i delete the sb3 lua folder and the ls3 folder i get the stole not active error[/QUOTE] add me on steam, so I can help without crowding up the thread.
  • Avatar of Hvaenngard
  • Seeing as you are working to improve Spacebuild, You think you could fix something in LS2? It might be out of your jurisdiction, but the resource pumps were way better. You would press E on one pump, and it would drop a plug that you would carry with your gravgun to the other pump. Now you just use a menu to do stuff, and you can't even see the connection! Again, you probably have your hands full with this, but LS3 development seems dead, and it'd be awesome if you could improve LS3 or better yet, include the improved pumps in this mod.
  • Avatar of LemONPLaNE
  • [QUOTE=Hvaenngard;29659802]Seeing as you are working to improve Spacebuild, You think you could fix something in LS2? It might be out of your jurisdiction, but the resource pumps were way better. You would press E on one pump, and it would drop a plug that you would carry with your gravgun to the other pump. Now you just use a menu to do stuff, and you can't even see the connection! Again, you probably have your hands full with this, but LS3 development seems dead, and it'd be awesome if you could improve LS3 or better yet, include the improved pumps in this mod.[/QUOTE] It's already implemented, at least he showed it to me a few weeks ago.
  • there maybe a bad reaction between this and superllamas new gravityhull because it causes you to float around :D dunno which one is causing it
  • Avatar of CmdrMatthew
  • It's superlamas fault. He's causing the player to actually leave the planet, he tried to fix this by faking the player's position, but that doesn't work with my add-on. Feel free to pester him to fix this, I will too.
  • Avatar of LemONPLaNE
  • [QUOTE=CmdrMatthew;29676393]It's superlamas fault. He's causing the player to actually leave the planet, he tried to fix this by faking the player's position, but that doesn't work with my add-on. Feel free to pester him to fix this, I will too.[/QUOTE] You need to meet halfway. I'm pretty sure modifying his code, hacky and huge as it is, is a bit harder than modifying yours. Ask him what you can do to help ease it.
  • Avatar of CmdrMatthew
  • [QUOTE=LemONPLaNE;29676500]You need to meet halfway. I'm pretty sure modifying his code, hacky and huge as it is, is a bit harder than modifying yours. Ask him what you can do to help ease it.[/QUOTE] This issue of his breaks many things, like shields, not just my issue. Also, he needs to fix what he breaks, especially if its functions core to the operation of the Source Engine, like ENT:Touch(), it relates to physics, brushes, almost everything.
  • Avatar of BoxMonster
  • If you die with Environments installed while you also have [url=http://www.garrysmod.org/downloads/?a=view&id=66218]DeathFix[/url] installed, your corpse is invisible, but it still leaves a shadow (it's pretty funny looking), as well as a headless (I think), reference-posed, floating Combine Elite. This happens even if I disable the spacesuit using the console. Deathfix applies any transformations of the player model to the resulting corpse (flaming, materials, inflation, etc.), so if you made the suit vanish and the body reappear when the player dies, that [i]might[/i] fix the issue. :) Also, could you make the Environments spacesuit automatically disable when in a non-Spacebuild map? You could keep the helmet (for underwater use), but have it default to off when the player spawns. Thanks!
  • Avatar of CmdrMatthew
  • That is a good idea, I will try to do that for non-sb maps. For the suit issue, idk, you can try to disable the suit in the autorun file, by setting Environments.UseSuit to false.
  • An error that may or may not be related to Environments is that I can't spawn the terraforming items at all. This is from a fresh install of Gmod using only wire, environments, LS3, SB3, and the gravity hull thing. I've also only tried to terraform on sb_gooniverse.