• PCMod 2 - Release Inside
    669 replies, posted
  • Avatar of Ronster
  • Sorry if i have missed it in a previous post, but i am having two more problems :(. I have DarkRP and New Admin installed 1. When a computer tech is present, everyone else can still buy computer parts (not spawn). 2. No one can interact or use other peoples PCs or read print offs Unfortunately i can't fix it myself, but i have tried. There are no error messages or anything else, just plain and simply how i have put it. Any help appreciated. Thanks :)
  • Avatar of Ronster
  • Sorry if i have missed it in a previous post, but i am having two more problems :(. I have DarkRP and New Admin installed 1. When a computer tech is present, everyone else can still buy computer parts (not spawn). 2. No one can interact or use other peoples PCs or read print offs Unfortunately i can't fix it myself, but i have tried. There are no error messages or anything else, just plain and simply how i have put it. Any help appreciated. Thanks :)
  • Avatar of thomasfn
  • There seems to be something with NewAdmin that stops you from using other people's entity - at least, either it's NewAdmin, or it's the prop protection you use. As for the computer tech thing, ensure that you have the latest PCMod version (2.0.4) and that the DarkRP plugin is installed in the correct place. (addons/pcmod2/lua/pcmod/plugins/)
  • Avatar of Ronster
  • Thanks :) And by the looks of it, its the prop protection that comes with DarkRP because when i disable the gamemode, i no longer get that problem. Note: sorry for the double post
  • Avatar of chicob
  • new problem i get these now ULib/server/hook.lua:139: attempt to index local 'gm' (a nil value) when i save and pcmod/ssdevices/dev_win_printloc.lua:36: attempt to index field '?' (a nil value) when i print
  • Avatar of thomasfn
  • Update your ULX to the latest, it's fixed in that. It might also fix the printing thing, not sure.
  • Avatar of infinitywrai
  • in the chatserv, if you connect a new computer to an existing network that has chat in it, the old chat is in the window and any new chat is overwritten on it...
  • Avatar of Valeour
  • NewAdmin is really restrictive over entities, if you have no priviledges in NewAdmin, you can't spawn entities.
  • Avatar of DevonX
  • When i try to type in my password this happends pcmod/ssdevices/dev_win_password.lua31: atempt to call method 'draw buttons' (a nill value) loops and the map breaks [URL=http://img520.imageshack.us/my.php?image=gmmobenixv30000.jpg][IMG]http://img520.imageshack.us/img520/3261/gmmobenixv30000.th.jpg[/IMG][/URL]
  • Avatar of Blt950
  • This PCmod 2 is awsome, but it of cource needs some fixes as all things and addons need. It wuld be great to have a software that you can install at PCs there you can restrict things at PC. So example it removes "Toggle Power", point with that is that you can make Cafè PC's, that example people need to pay for to use (RP) and then you turn on PC. Btw: Is it wire output that you can turn on/off pc?
  • Avatar of Valeour
  • Not that i know of. But you can just use a Wire User. You could do what they do in game stores and keep the computer case in a glass case so people can't touch it, and use a wire user to turn it on.
  • [QUOTE=DevonX;14250704]When i try to type in my password this happends pcmod/ssdevices/dev_win_password.lua31: atempt to call method 'draw buttons' (a nill value) loops and the map breaks [URL=http://img520.imageshack.us/my.php?image=gmmobenixv30000.jpg][IMG]http://img520.imageshack.us/img520/3261/gmmobenixv30000.th.jpg[/IMG][/URL][/QUOTE] I got that to so i tried to use No password at all, and then it worked.
  • Avatar of ogradyc
  • [QUOTE=DevonX;14250704]When i try to type in my password this happends pcmod/ssdevices/dev_win_password.lua31: atempt to call method 'draw buttons' (a nill value) loops and the map breaks [URL=http://img520.imageshack.us/my.php?image=gmmobenixv30000.jpg][IMG]http://img520.imageshack.us/img520/3261/gmmobenixv30000.th.jpg[/IMG][/URL][/QUOTE] I have a very similar problem to this one when i was playing on my friends server and i opened the print dialogue, something like atempt to call something '?' and the map thing would happen thats when the printer wasn't connected properley. Then i tried it again with the printer connected and it crashed the server. Then i tried in single player, it froze my gmod and i had to kill task.
  • Avatar of ogradyc
  • [QUOTE=gmt2001;14317764]Get the latest SVN and tell the server owner to do so too[/QUOTE] I have just got latest svn and when on flatgrass it works it prints fine but if i am on RP_evocity_v2d it does this map thing and gives me this error pcmod/ssdevices/dev_win_printloc.lua:36: attempt to index field '?' (a nil value) then when i put in IP address and press print it freezes i have ULX and it does it but my friend has newadmin and that one does it to
  • Hello ThomasFn! Sorry if i will say this but on my previous gameplay i can use my pc made from this mod but this time it does not zoom in to the monitor and the mouse wont move Please Help me One More Thing it also appears in my error of lua ovveride please help
  • Avatar of Valeour
  • Try to copy and paste the error into this forum, it will give Thomas (and other) a clear idea... If you don't know how to copy the error, open up the console when you do get the error and it will be in there. I'm also guessing you don't know what a console is, so go to the main menu, options, Keyboard, Advance, and tick the developer console, then press okay, and when you get the error, press ` (left of the number 1, just under escape) and you'll be able to copy from there.
  • Ok i have looked into the 2 problems above. The dev_win_password one can be solved by getting the latest SVN revision. The dev_win_printloc one can be solved by editing the file and adding the following to the bottom of the function DEV:Initialize [lua] if(!PCMod.SDraw.DevParams[ self.EntID ]) then PCMod.SDraw.DevParams[ self.EntID ] = {} end if(!PCMod.SDraw.DevParams[ self.EntID ][ "window_printloc" ]) then PCMod.SDraw.DevParams[ self.EntID ][ "window_printloc" ] = {} end[/lua]
  • Avatar of thomasfn
  • Ok I commited the fix to the SVN. Update your SVNs to the latest. (Oh yeah and gmt, get a new avatar please -_-)
  • Avatar of Jimmy422
  • [QUOTE=Jimmy422;13740924]How do you change the color of the BIOS and the text it displays? I can't find it in any of the configs.[/QUOTE] Anyone?
  • Avatar of thomasfn
  • The colour is defined in pcmod2/lua/pcmod/ssdevices/dev_bios.lua, or something like that. Just look for the Color keyword, probably in the DEV:Paint function. The text is defined in a mixture of places, not really easy to edit that. Look at the bios driver (pcmod2/lua/pcmod/drivers/bios.lua), and in the baseconfig file's codes table.
  • Avatar of infinitywrai
  • [QUOTE=infinitywrai;14243906]in the chatserv, if you connect a new computer to an existing network that has chat in it, the old chat is in the window and any new chat is overwritten on it...[/QUOTE] Was this fixed? Sorry for hard to read sentence but it's a very annoying bug! Also if you walk away from a comptuer while it's booting, it gets stuck! Custom songs aren't working (tried in all of the last 3 versions) Also pcmod/cl_2d3d.lua:332: attempt to compare nil with number
  • How do i put my Own music in the "Custom" tab? Or is it possible you can add Team Fortress 2 To the Media Player? :p UI\gamestartup1.mp3 UI\gamestartup2.mp3 UI\gamestartup3.mp3 Are the Path to them.
  • Avatar of Wickedgenius
  • Because I am a little too lazy to read all 10 pages of this thread, has anyone made any applications yet?