• PCMod 2 - Release Inside
    669 replies, posted
in rp mode you have to rp buy in pcmod 2. i believe the chat command was !pcbuy Starbank isnt on pcmod 2 because there's no table element and all the text and stuff is bigger, thus making it impractical
[QUOTE=BloodShed;14659548]I made a video tutorial on how to add music to pcmod2 [media]http://www.youtube.com/watch?v=zei-Zj0cdAs[/media][/QUOTE] Thanks, Really liked it. Helped me alot. Question: Why doesnt pc mod 2 have all the old programs?
Because, PCMod 2 uses a completely different interface from PCMod 1. All the "old" programs would need to be rewritten to work with PCMod 2, and quite frankly, I don't have the time. Most of the stuff is there though, what are you missing in particular? (Don't say starbank.)
What's starbank?
[url]http://www.garrysmod.org/downloads/?a=view&id=64899[/url]
Neato. Lets get that back!
As I have explained before, I have no plans on remaking starbank for pcmod 2 myself. If anyone else wishes to attempt it, feel free.
What are the commands to increase the limit of Towers/Laptops you can have?
shouldn't it be something like sbox_maxpc_whatever
'sbox_maxpcmod_blah 10' done through rcon. Or you can use 'pc_setlimit tower 10' if you're an admin from your client console (no rcon needed for that).
I have a question, I downloaded PCmod 2 (I think 2.0.4 or whatever) and I put it in my addons and when I try to use it in gmod, the PCmod tab doesn't show up. I'm not sure what the problem is please tell me.
Your problem is that you've not given me enough information to help me. Check your console for any errors. You really should get the SVN, it has lots of updates that I haven't published on garrysmod.org.
Is there a way you can make a splitter support MANY more speakers? I liked that bug/feature in PCMod 1 Also, a way to add music to it EASILY (for a minge like me)
[QUOTE=iforgotaboutit;15206789]Is there a way you can make a splitter support MANY more speakers? I liked that bug/feature in PCMod 1 [/QUOTE] this can be done if the server host edits the entity edit pcmod2/lua/entities/pcmod_splitter.lua jsut add more copies of the port creation line in the initialize function until you ahve the desired number of ports
Adding music requires anyone who joins to download it. I would prefer to see a streaming setup so people didn't have to download the files.
Streaming music in Garry's Mod is not possible without binary modules on both server and client, without a hacky HTML panel or something. It's not worth the effort.
So... is this not being worked on anymore?
[url]http://www.fortfn.co.uk/forum/showthread.php?tid=258[/url]
[QUOTE=Lancelot;15215797]Adding music requires anyone who joins to download it. I would prefer to see a streaming setup so people didn't have to download the files.[/QUOTE] I think what he meant by adding more music was be able to add more songs already on the client machine (like the portal songs)
Absolutely awesome mod! Do have a question though, and since the search term "lag" is too short for Vbulletin's liking, I don't know if it was addressed yet or not: The occasional "This server uses PC Mod 2" (or similar) message which pops up is causing extreme lag on a non-dedicated server - that is, one running on my home computer. It is either the message itself, the code which pops up the message, or something that happens at the same time as the message causing the lag. No errors are involved, it just lags when that message displays. This isn't a problem for similar messages from other mods, only this one. Any ideas? I'd prefer to leave the 'ad' in because it promotes the mod, but if nobody can advise of a solution, I'll be forced to hack up the code trying to remove it...it's simply unplayable like this.
Aww I was hoping this would die...
Just remove the message, in the config files. I think I added a nice line of code called "cfg.ShowTimedMessage = true" or something.
This mod conflicts with this mod: [url]http://www.garrysmod.org/downloads/?a=view&id=49808[/url] Which makes me sad because they're both my favorite mods ever, and I want a computer system on my spaceships. Can anything be done about this?
Explain how it conflicts, I see no reason for it to.
[QUOTE=thomasfn;15706247]Explain how it conflicts, I see no reason for it to.[/QUOTE] If I have both installed and fly one of the ships, the view (instead of being toggleable with a zoomin,zoom out function) is stuck inside the very center of the ship and when the ship moves the camera tries to move with it but rubberbands constantly and enough to induce a headache if you fly it enough. Pcmod 1 didn't conflict with the ships so I'm guessing it's something to do with not using derma and the "zoom in to the monitor" thingy, but I know nothing of lua so I have no idea. Also I'm positive these two mods are the ones conflicting I've had only both of them installed, and when I remove pcmod2 the spaceships view is perfectly fine.
Is there an PCMod 2 Plugin 4 the new official Dark RP?
[QUOTE=thomasfn;15705256]Just remove the message, in the config files. I think I added a nice line of code called "cfg.ShowTimedMessage = true" or something.[/QUOTE] Thanks, got it sorted. Lag seems to be gone...gotta wonder why it happened but important thing is it's gone.
Is it me or does PC mod not work with lots of things (network stuff in particular)
To get PCMod 2 should I remove 1, or will they run simultaneously?? Thanks
Now, maybe it's just my hardware (not quite fast enough?)...but I have to report a game-crasher I found. On gm_zonstruct in SP, I was working on some "idea generation" as I call it (coming up with ideas for MP with buddies later). If you know the map, you'll see the potential for what I'm about to describe. Across the map there are several areas which are suitable for multi-computer offices. I went around stringing up some electrical wire poles with cable ties all over the map, and cable ties down into the basement tunnels, and then proceeded to create several offices. Structure went like: Backbone router (1x) - router (8x) - computers (1 server w/printer per router, 4 personal computers per router) According to that, I had 32 personal computers and 8 servers. Each server had a shared printer. I set up one server how I wanted it (printer sharing enabled), copied the hard drive and went to all servers putting the copy on them. Turned em on, then went to the personal computers. Set up one how I wanted it, took out the hard drive copier, copied it, then went to paste it and the game disappeared off my screen. No warning, nothing, just GONE. Not even an End Task dialog! I checked task manager and hl2.exe was gone. Is this the result of a bug or is this more likely relating to hardware? I normally perform quite well in Gmod in general, I won't go into detail with specs unless you want em. edit: should mention, am using garrysmod.org copy of 2.0.4. I refuse to use SVN client software and am therefore waiting on next full release on the site. I don't have a damned clue how this is 'dumb', but go ahead FP, say what you will...just figured I'd help out the mod maker by making him aware of what happens when you make a network like that with 2.0.4.
Sorry, you need to Log In to post a reply to this thread.