• PCMod 2 - Release Inside
    669 replies, posted
[QUOTE=jiggu2;13736207]If you press the fast type button then i think you can type with your keyboard, no promises.[/QUOTE] I know how to use it because i mean use my keyboard without this "Fast Type" : P
Like I've explained, not possible to do in gmod without a module. Or some really sneaky hook that nobody even knows about.
[QUOTE=thomasfn;13740562]Like I've explained, not possible to do in gmod without a module. Or some really sneaky hook that nobody even knows about.[/QUOTE] Check your PMs, I gave a perfectly working solution.
I was going to get back to you about that actually. I couldn't download the file, the stupid site spammed my pc with popups and then crashed my browser. Twice. So I gave up.
[QUOTE=thomasfn;13740690]I was going to get back to you about that actually. I couldn't download the file, the stupid site spammed my pc with popups and then crashed my browser. Twice. So I gave up.[/QUOTE] [url]http://luabin.foszor.com/1969[/url] [url]http://luabin.foszor.com/1970[/url]
How do you change the color of the BIOS and the text it displays? I can't find it in any of the configs.
[QUOTE=Valeour;13734888]@Achilles123: The reason this benefits a server, is because it's good for role playing reasons. And is fun to have on big wire contraptions. And to make them chat, the routers need to be connected. Wireless isn't an option at the moment i don't think. You could try setting the wires to 0 so they're invisible. [/QUOTE] Thanks! However, by server, I meant on the in-game computers, not an actual Gmod server. And for the routers, for them to be connected, you mean use the wire tool to connect both computer towers to the same router? Or what?
[QUOTE=Kogitsune;13740724][url]http://luabin.foszor.com/1969[/url] [url]http://luabin.foszor.com/1970[/url][/QUOTE] This. It's so much better than the thing you use now. By the way, Computers won't render if they aren't in your viewport, do they? If they do, change that. Possibly combine it with something so they don't render from less than 1024 units or whatever.
...People... Just read the fucking thread before you fucking post, then you save yourself the embarrasment of asking an already awnsered question. Also, Achillies, i was on about the in-game computers too. You connect them to the same router or figure out how to use a backbone router. (I have no idea how to work the backbone.)
[QUOTE=thomasfn;13737957]So any problems with the new patch? Has anyone even tried it? Or does it work so well everyone is stunned and can't speak? [/hopefullness][/QUOTE] Haven't tried the patch, but i am a stunned mullet atm, very nice mod. Sometimse the router will glitch and not give an IP, (its happened once so I'll need to play some more :) ) but none the less, very good job :) Suggestion: Any plans for a data server? edit: [QUOTE=Valeour;13743286]...People... Just read the fucking thread before you fucking post, then you save yourself the embarrasment of asking an already awnsered question. Also, Achillies, i was on about the in-game computers too. You connect them to the same router or figure out how to use a backbone router. (I have no idea how to work the backbone.)[/QUOTE] From what i have seen, use the wiring tool to link the fibre port of the std router to a free port on the backbone router :) I'll post my exp soonish edit2: ChatServ is buggy :| when i try to open the application i get [code] pcmod/programs/pr_chatserv.lua:31: attempt to index global 'ss' (a nil value) [/code] then when i try to connect it hangs at "Waiting for response" (all errors etc) [code] pcmod/programs/pr_chatserv.lua:31: attempt to index global 'ss' (a nil value) 1 = netChat_Register 2 = mrpuffy 1 = netChat_Register 2 = mrpuffy 1 = netChat_Register 2 = mrpuffy pcmod/programs/pr_chatserv.lua:31: attempt to index global 'ss' (a nil value) This server uses PCMod 2.0.0! Saving achievements... 1 = netChat_Register 2 = mrpuffy [/code]
I know I am being a consistent bugger, but in the "PCMod 2 Public Beta Testing" thread, you said you were going to look into the BSOD. So far I've seen nothing in the way of one, are you planning to add one in, in PCMod 2.0.2? (or PCMod 3)
make a svn version!!
Few other bugs i have noticed pc - router - backbone - router - pc, neither pc can see each other (ping test sits there for 10000 years.) Also thomasfn, your server has no prop protection and your anti-spam thingy stops people from welding their shit to the ground when a minge attacks -_- edit: another problem i found (though unlikely to happen) is that after 250+ routers are spawned it stops spawning if you keep on trying it results in console spam [code] **************************************************************** PCMod2: Entity has no data slot! (385) **************************************************************** Error calling die function Cleanup_Data_385 for entity Entity [385][pcmod_router] ERROR: entities/pcmod_base/shared.lua:63: bad argument #1 to 'pairs' (table expected, got nil) **************************************************************** PCMod2: Entity has no data slot! (386) **************************************************************** Error calling die function Cleanup_Data_386 for entity Entity [386][pcmod_router] ERROR: entities/pcmod_base/shared.lua:63: bad argument #1 to 'pairs' (table expected, got nil) **************************************************************** PCMod2: Entity has no data slot! (387) **************************************************************** Error calling die function Cleanup_Data_387 for entity Entity [387][pcmod_router] ERROR: entities/pcmod_base/shared.lua:63: bad argument #1 to 'pairs' (table expected, got nil) **************************************************************** PCMod2: Entity has no data slot! (388) **************************************************************** Error calling die function Cleanup_Data_388 for entity Entity [388][pcmod_router] ERROR: entities/pcmod_base/shared.lua:63: bad argument #1 to 'pairs' (table expected, got nil) **************************************************************** PCMod2: Entity has no data slot! (389) **************************************************************** Error calling die function Cleanup_Data_389 for entity Entity [389][pcmod_router] ERROR: entities/pcmod_base/shared.lua:63: bad argument #1 to 'pairs' (table expected, got nil) **************************************************************** PCMod2: Entity has no data slot! (390) **************************************************************** Error calling die function Cleanup_Data_390 for entity Entity [390][pcmod_router] ERROR: entities/pcmod_base/shared.lua:63: bad argument #1 to 'pairs' (table expected, got nil) **************************************************************** PCMod2: Entity has no data slot! (391) **************************************************************** Error calling die function Cleanup_Data_391 for entity Entity [391][pcmod_router] ERROR: entities/pcmod_base/shared.lua:63: bad argument #1 to 'pairs' (table expected, got nil) **************************************************************** PCMod2: Entity has no data slot! (392) **************************************************************** Error calling die function Cleanup_Data_392 for entity Entity [392][pcmod_router] ERROR: entities/pcmod_base/shared.lua:63: bad argument #1 to 'pairs' (table expected, got nil) **************************************************************** PCMod2: Entity has no data slot! (393) **************************************************************** Error calling die function Cleanup_Data_393 for entity Entity [393][pcmod_router] ERROR: entities/pcmod_base/shared.lua:63: bad argument #1 to 'pairs' (table expected, got nil) **************************************************************** PCMod2: Entity has no data slot! (394) **************************************************************** Error calling die function Cleanup_Data_394 for entity Entity [394][pcmod_router] ERROR: entities/pcmod_base/shared.lua:63: bad argument #1 to 'pairs' (table expected, got nil) **************************************************************** PCMod2: Entity has no data slot! (395) **************************************************************** Error calling die function Cleanup_Data_395 for entity Entity [395][pcmod_router] ERROR: entities/pcmod_base/shared.lua:63: bad argument #1 to 'pairs' (table expected, got nil) **************************************************************** PCMod2: Entity has no data slot! (396) **************************************************************** Error calling die function Cleanup_Data_396 for entity Entity [396][pcmod_router] ERROR: entities/pcmod_base/shared.lua:63: bad argument #1 to 'pairs' (table expected, got nil) **************************************************************** [/code] Although what are the chances that in a game, the whole server will go through 250+ routers? edit (number unknown): On a positive note :), I love the cable ties, they're great for keeping them cables neat and tidy. [url=http://www.uploadandgo.com/gallery.php?entry=images/gm_construct0040.jpg][img]http://www.uploadandgo.com/thumbs/gm_construct0040.jpg[/img][/url][url=http://www.uploadandgo.com/gallery.php?entry=images/gm_construct0043.jpg][img]http://www.uploadandgo.com/thumbs/gm_construct0043.jpg[/img][/url]
I want a SVN version of the pcmod 2! :)
I am sorry to say that this does not work for me or my server. Proplems, The Score pannel wont come up now, and it wont spawn any of the pc models. Through the Toolgun sorry :(.
How can i remove the pcmod menus fro the q menu, i want only to see the pcmod wire menu, because with the others, people still make pcs even if they aren't computer technichans and how can i add custom songs for personal player?
will we get notebooks?
... [QUOTE=Pizzi;13745296]make a svn version!![/QUOTE] [QUOTE=Grocel;13749344]I want a SVN version of the pcmod 2! :)[/QUOTE] You two, read the fucking OP. At the bottom. (OP = Opening post) [QUOTE]and how can i add custom songs for personal player?[/QUOTE] Go back a fucking page. [QUOTE]I am sorry to say that this does not work for me or my server. Proplems, The Score pannel wont come up now, and it wont spawn any of the pc models. Through the Toolgun sorry :(. [/QUOTE] Read the thread, we've discussed this, and there's a patch. I'm sorry for being bitchy, but it's REALLY doing my head in. Also, thomas, mbainrot has just reminded me, the routers do infact sometimes not show IP addresses. [/rant]
Yes I am aware of the router problem. Gmt2001 is investigating it now. Also, at 250+ routers, I think what is happening is that you run out of IP addresses... I can't remember how it handles subnets (I didn't write that bit, gmt did). And for all those who have no idea what back bones do, here is an explanation: Network ports are used to connect towers to routers. They are NOT used to connect routers to routers, or routers to backbones. Optic ports are used to connect routers to backbones, or vice versa. Since a router only has 1 optic port, a network without backbones could only consist of 2 routers and 8 towers in total (since a router has 4 network ports). This is very limiting. The backbone has 0 network ports but 10 optic ports. This means you can connect 10 routers together. This allows for 40 towers in total - and thats only 1 backbone. Without backbones, the only way to connect big networks up is via wireless. [b]Edit:[/b] Oh yeah and Valeour, I too get pissed off with people who don't read the whole thread. You're not alone ;) [b]Edit2:[/b] And thanks for that module Kogitsune, I will look into adding it in asap.
That backbone thing is really clever... I want your brain.
I have a problem with this mod! Everytime (in SP) when I try to save my game (with PCMod) none of my computers work when I load the savegame back. Any solution for this?
uhm, where should i put the song file?
You won't be able to use save game option with this. The save game screws up everything that isn't a normal prop, and unless Garry completely rewrites the whole savegame and adds loads of hooks to it, I'm not even going to look into adding support. The extra song files should go in garrysmod/sounds/music/blah/mp3.
[QUOTE=thomasfn;13752289]You won't be able to use save game option with this. The save game screws up everything that isn't a normal prop, and unless Garry completely rewrites the whole savegame and adds loads of hooks to it, I'm not even going to look into adding support. The extra song files should go in garrysmod/sounds/music/blah/mp3.[/QUOTE] And for some reason Adv Dup does not work with this too?
I tried to make the entities adv dupe compatible, and it was working at one point but it isn't easy to do you know... if you want to adv dupe your pcmod based contraptions, unwire everything first. When you paste it all, everything should still work once rewired - just that the tower's hard-drives will be reset.
[QUOTE=Phsykotik;13715667]It'd be great if we could just type and not have to use the on-screen keyboard.[/QUOTE] Use quicktype then. You can access it either by clicking Quicktype underneath the close button or by typing !pctype into chat [QUOTE=Valeour;13715824] Also, when you try to print unsaved files, you get a blank paper.[/QUOTE] We are aware of this. Currently you cannot really do anything with a notepad document other then type it up until you save it [QUOTE=mbainrot;13743639]Sometimse the router will glitch and not give an IP, (its happened once so I'll need to play some more :) )[/quote] See 2nd paragraph of the note below [QUOTE=Valeour;13751974]That backbone thing is really clever... I want your brain.[/QUOTE] Was my idea ^_^ [QUOTE=JimiRobaer;13752333]And for some reason Adv Dup does not work with this too?[/QUOTE] Works if you unwire everything before duping, you will lose the towers hard drive though. If you are going to be pasting it back on the same GMOD server anyway then you can use the HD Copier which will save hard drives to the servers data folder, then after pasting you can paste the hard drive to it NOTE: Quicktype appends whatever is already there, you still have to labor over erasing things with the onscreen keyboard For anyone whos having trouble with removing devices, specificly networking, where it doesnt seem to work right if you then spawn another a fix has ben found and will be included in a bug fix release soon For anyone thats having trouble using textboxes because the cursor doesnt go where it should, we are working to figure this one out NOTE2: Wireless routers may not be working yet NOTE3: Routers use the standard LAN subnet of 192.168 and backbones use the other standard LAN subnet of 10.0 which means that only 255 routers of each type can be on the server at any given time Also backbones can be connected to backbones
Ok the public SVN is now up: [url]http://pcmod.googlecode.com/svn/pcmod2/[/url] Delete your existing PCMod folder. Then, create a new empty folder in your addons folder called 'pcmod2'. Right click, SVN checkout, use above url.
My question is.. Why should I upgrade to this? Last time I tested PCMod2, it had so many huge bugs I couldn't really even try it.
[QUOTE=thomasfn;13752737]Ok the public SVN is now up: [url]https://pcmod.googlecode.com/svn/pcmod2/[/url] Delete your existing PCMod folder. Then, create a new empty folder in your addons folder called 'pcmod2'. Right click, SVN checkout, use above url.[/QUOTE] Can't use svn. Need username and password. You did never mention about that.
The right link is: [url]http://pcmod.googlecode.com/svn/pcmod2/[/url] He has a typo in his link. :)
Sorry, you need to Log In to post a reply to this thread.