• Advanced Duplicator 2
    1,090 replies, posted
  • Avatar of medal-12
  • Where do i install this to, i've put it into my addons folder, but it doesn't show up in the game
  • Avatar of -TB-
  • [QUOTE=medal-12;33849844]Where do i install this to, i've put it into my addons folder, but it doesn't show up in the game[/QUOTE] Take the folder thats called AdvDupe2 out of the folder you downloaded it into and put that into your addons.
  • Avatar of Jackarunda
  • [IMG]http://thelaughingmarcus.files.wordpress.com/2009/08/so-much-win.jpg?w=445[/IMG] [highlight](User was banned for this post ("Image macro" - Swebonny))[/highlight]
  • Avatar of gamerpaddy
  • Ghosts will not disappear by large constraptions or constraptions with a lot constraints.. You have to unfreeze Dupes to use it with smartsnap Deselect "spawn with parents" not saving by Dupe another prop and.. Some users on my server have problems with lag on open the dupe2 toolmenu
  • [QUOTE=gamerpaddy;33852807]Ghosts will not disappear by large constraptions or constraptions with a lot constraints.. You have to unfreeze Dupes to use it with smartsnap Deselect "spawn with parents" not saving by Dupe another prop and.. Some users on my server have problems with lag on open the dupe2 toolmenu[/QUOTE] If you were smart, you'd use five minutes of your precious time and read the thread. You'd be able to solve nearly all those issues perfectly.
  • Avatar of -TB-
  • [QUOTE=gamerpaddy;33852807]Ghosts will not disappear by large constraptions or constraptions with a lot constraints.. You have to unfreeze Dupes to use it with smartsnap Deselect "spawn with parents" not saving by Dupe another prop and.. Some users on my server have problems with lag on open the dupe2 toolmenu[/QUOTE] I can't understand most of that but most of it just sounds like user error and lack of comprehension of bugs and features. The tool menu shouldn't lag unless maybe it's a low end computer and there are many AD1 files in their data folder.
  • Avatar of mn_chaos
  • I dont see any slider problems, although the ghost sometimes misses pieces when my cpu is under stress. Dupes nearly perfectly though. Follow what Amplar said, having an overwriting autosave entity will save file space and help absentminded people like me from losing contraptions.
  • Avatar of Unslinga
  • Still some problems at hand: Smartsnap grid not showing after paste I'm not sure about that thing with smartsnap, it seems that it's only some parented props, and wheel2 props that have the grid. What is causing this problem? now the ghosted props remain after paste This started to happen after I updated to rev 36. getting loads of lua errors trying to set height to negative. Haven't seen this mentioned before.
  • Avatar of Metamist
  • [QUOTE=Unslinga;33922600]Still some problems at hand: Smartsnap grid not showing after paste I'm not sure about that thing with smartsnap, it seems that it's only some parented props, and wheel2 props that have the grid. What is causing this problem?[/QUOTE] That's a gmod bug. He made a little work around, enable the 2nd option in the Experimental section.
  • Also, a little known tool called Wire Piston does not save properly with AD2.
  • Avatar of Phoenixf129
  • [code] [28 Dec 2011 02:59PM] ERROR: Hook 'AdvDupe2_Spawning' Failed: [addons\advdupe2\lua\advdupe2\sv_clipboard.lua:1183] attempt to index local 'Queue' (a nil value) [28 Dec 2011 02:59PM] [addons\advdupe2\lua\weapons\gmod_tool\stools\advdupe2.lua:814] attempt to index field 'GhostEntities' (a nil value) [/code]
  • Avatar of mn_chaos
  • Fuck. Center ballsockets now lose their collsion box AND smartsnap grid. I know it is the collision box too because I have a inboard hud which tells me world angle and position, collision box surface area and client netgraph. The ballsocket center props never show up and fall through world. It does wonders for adv ballsocket though. It saved Harbringer's tank.
  • Avatar of Unslinga
  • Can you have a checkbox to disable ghosts? that would at least help on the ghost problem...
  • Avatar of vexx21322
  • [QUOTE=Unslinga;34012626]Can you have a checkbox to disable ghosts? that would at least help on the ghost problem...[/QUOTE] You can set it to show % of ghost, just change it to 0.
  • Avatar of Concept
  • I cant save or delete. I right click to ghost the item, but when I click save nothing happens or pops up.
  • Avatar of -TB-
  • [QUOTE=mn_chaos;33989325]Fuck. Center ballsockets now lose their collsion box AND smartsnap grid. I know it is the collision box too because I have a inboard hud which tells me world angle and position, collision box surface area and client netgraph. The ballsocket center props never show up and fall through world. It does wonders for adv ballsocket though. It saved Harbringer's tank.[/QUOTE] I'm not sure what you mean by center ballsockets, and constraints don't have physics objects so I'm even more confused. [QUOTE=Concept;34068508]I cant save or delete. I right click to ghost the item, but when I click save nothing happens or pops up.[/QUOTE] Did you enter something for the name of the file? and check the console for errors or notifications.
  • Is there a mirror to the file since my Tortoise SVN is severely messed up.
  • Avatar of LemONPLaNE
  • [QUOTE=Luke-N;34083813]Is there a mirror to the file since my Tortoise SVN is severely messed up.[/QUOTE] Uninstall it and install a [I]good[/I] client, like Slik.
  • Avatar of -TB-
  • [QUOTE=Luke-N;34083813]Is there a mirror to the file since my Tortoise SVN is severely messed up.[/QUOTE] No mirrors, so that there wont be a bunch of different versions floating around. [QUOTE=Concept;34071686]Yea I entered a name for the file, and gave it a description.[/QUOTE] And as for the console?
  • Avatar of -TB-
  • [QUOTE=Concept;34086011]Haven't modified a thing.[/QUOTE] Huh? Open the console with the tilde key ~ after you try saving and see if it says anything pertaining to AD2. You may have to enable the developer console in the options menu.
  • Avatar of -TB-
  • [QUOTE=mn_chaos;34106987]The ballscket center tool I mean.[/QUOTE] I tested the tool and it duplicated without any problems. The problem you report still doesn't make any sense.
  • Avatar of mn_chaos
  • the ballsocket center tool when used between two props or prop and world when duped with advdupe2 will dupe sagging ballsockets that do not correctly constrain the two entity together. (For example, if I constrain two plates with the ballsocket center tool with x,y and z set to 90/-90, the tool dupes them with sagging constraints and certainly DOESNT spin with the correct restraint input in the first place. This occurs with world too. I hope that explained the matter better.
  • Avatar of -TB-
  • I just need to know the exact values for every option on the tool, cause I did what you said and I'm not getting anything that comes close to spinning. Xrotmin set to 90 Xrotmax set to -90 and same for y and z with nothing else checked. Just out of curiosity do you have TB's duplicator installed?
  • Avatar of Anticept
  • I've added you to friends on steam -TB-, I'd like to talk about integrating AD2 and making it part of wire... Just kidding. But seriously, if this addon works, I see no reason to keep AD1 in wire, and just bridging it to your repo with an svn:external. I would like to ask permission though, if you disappear or stop maintaining it, that the wireteam would be able to take over. EDIT: What, no credit to TAD2020 for his original Adv Dupe? :P [QUOTE=Failure;33068365]That's great. Finally I can have this useful thingy without the god damned wire.[/QUOTE] We've never had AD1 rely on wire. The only reason it was ever packaged alongside wire is because TAD2020 was also developing wiremod, and our subversion repository was a convenient place to put it. /shrug
  • Avatar of gamerpaddy
  • hello again, got this error: [AdvDupe2Notify] Could not open [@addons/advdupe2/lua/advdupe2/sv_codec.lua:645] attempt to read AD2 file with malformed info block i saved the dupes with rev,36 on my server.. i made a backup to my pc (via ftp) and after reinstall. i upload the files.. and the error appears... now on every server + Singleplayer :(