• Next Update v2
    3,675 replies, posted
Keep getting this after the update : mod_studio: MOVETYPE_FOLLOW with no model. Any suggestions on what it could be?
[QUOTE=broscodo;47290827]Our server occasionally crashes on SetNWBool[/QUOTE] [QUOTE=Ott;47290848]My server crashes on GetNWInt. Last update. Something to do with SQL.[/QUOTE] I set 3 different NWVars per player, I've had an average of 70 players through out the day and not a crash one.
Anyone else getting all weapons disappearing on darkrp?
[code] closedcaptions.Show() closedcaptions.Push(Color color, string text) closedcaptions.Hide() [/code] Now that closed captions have been re-implemented. Seeing these would be nice :D
[QUOTE=ImDesire;47291434]Anyone else getting all weapons disappearing on darkrp?[/QUOTE] Getting this bug for TTT if you're talking about missing view models.
[QUOTE=xthenarwhalx;47291636]Getting this bug for TTT if you're talking about missing view models.[/QUOTE] Yep.
Hahaha, all you guys and your NWVars. net message master race.
[QUOTE=Robotboy655;47288839]It was only working because of the infinite loop DLabel had. Use SetFGColor. The whole derma is a mess and needs redoing.[/QUOTE] I realize this is a small problem in comparison to others, but is this going to be a long-term issue? There is no corresponding label:GetFGColor() function, so now we have to either call label:SetTextColor() along with label:SetFGColor() to be able to use label:GetTextColor(), or we use label:GetColor() which doesn't even return a new Color object (it returns the old table method {r=,g=,b=,a=}). Also, does this only affect DLabels? Things like DTextEntrys still seem to have a functioning SetTextColor() function. If it's only DLabels, why not define label:SetTextColor() to internally call label:SetFGColor() and set m_colText to the passed param, that way label:GetTextColor() also works and we don't have a bunch of malfunctioning labels everywhere. [URL]https://github.com/garrynewman/garrysmod/blob/master/garrysmod/lua/vgui/dlabel.lua[/URL] [code] AccessorFunc( PANEL, "m_colText", "TextColor" ) -- no change here -- ... function PANEL:SetTextColor( color ) self.m_colText = color self:SetFGColor( color ) end[/code] It's slightly hacky but it's better than just dropping label:SetTextColor()'s original functionality. The only other thing we can really do is add a call to label:ApplySchemeSettings() every time we change the text color.
[QUOTE=ImDesire;47291768]Yep.[/QUOTE] PM Me your steam URL so I can add you and we can compare addons. I find it odd that you're DarkRP with the same issue, I doubt we have any addons in common but might as well try.
[code] Engine error: player/guerilla.mdl (2) at -1.$ -1.$ -1.$ in contact with world (2) at -4.0 -3.4 34.1, crash. dist = -1, minq = 99999999999999998000000000000000000000000000000000000000000000000000000000000000000000000000000000000.000000 [/code] Well, that's slightly different from the usual error.
[QUOTE=MuteTM;47292136][code] Engine error: player/guerilla.mdl (2) at -1.$ -1.$ -1.$ in contact with world (2) at -4.0 -3.4 34.1, crash. dist = -1, minq = 99999999999999998000000000000000000000000000000000000000000000000000000000000000000000000000000000000.000000 [/code] Well, that's slightly different from the usual error.[/QUOTE] [url]http://facepunch.com/showthread.php?t=1347114[/url]
[QUOTE=code_gs;47292163][url]http://facepunch.com/showthread.php?t=1347114[/url][/QUOTE] I'm running it already, it's appreciated. It doesn't appear the body hit the velocity required - it was bouncing around. Is there something else causing it?
[QUOTE=MuteTM;47292174]I'm running it already, it's appreciated. It doesn't appear the body hit the velocity required - it was bouncing around. Is there something else causing it?[/QUOTE] Try lowering the velocity; that's usually how it crashes is it bouncing
[QUOTE=MattJeanes;47245426]In my opinion it should say DD.MM.YYYY or YYYY.MM.DD or everyone's gonna think GMod 15 is a thing, [url=http://facepunch.com/showthread.php?t=1453721]like they do for 14[/url] :v:[/QUOTE] [url=http://facepunch.com/showthread.php?t=1455059]They're evolving[/url]
Anything new on the Linux client crash by chance?
[QUOTE=Ott;47292389][url=http://facepunch.com/showthread.php?t=1455059]They're evolving[/url][/QUOTE] At least it's unambiguous! Not yet that is. [editline]10th March 2015[/editline] [QUOTE=Robotboy655;47290055]What if I told you there are many more issue without tags? Will you be satisfied if I add all the possible tags?[/QUOTE] I think in that case, I would say: Oh, I hadn't realized. I didn't think it was personal FWIW, I noticed that there were others, I just assumed that they all weren't being acknowledged (as there is no indication that they were) and was genuinely wondering why.
Just going to throw in here that my gamemode, GangWarsRP is also broken with randomly crashing servers. I also wanted to question the logic of blaming developers because we didn't test your release. Obviously, if this version has been up for "6 months" and available for us to test - and yet NOBODY DID - then there is a flaw with this idealised vision of how to test updates? Personally, I host on dedicated machines and I don't really have the resources to host another srcds instance just for testing a dev branch that doesn't get a lot of attention and may not be released for months. Plus, how I could convince my players to install the test client for gmod and go onto this empty server, I don't know? At Unity Game Engine they have a similar issue that when they release updates they have the potential to break a lot of peoples games. So they have implemented an automated testbed system where they keep copies of some of the more popular games made within unity which are executed by the testbed (and in unities case, inputs are replicated into the game), logging error outputs and taking screengrabs. This is repeated on the current live code, and the developer branch of code. At the end the testbed can compare differences in the screenshots or errors logged, and flag up potential problems with the new update code! I accept this is a fair bit of work but I wanted to highlight that the idea of gmod devs like myself testing seemingly doesn't work, and that there are alternatives available.
I've so far had no crashes, however, I have an if statement in my HUD to check if a client has an NW bool, however, sometimes it causes the HUD to flash in and out, and I'm also sometimes unable to switch weapons.
I really like this update and hold nothing against Robotboy and Killburn for making Garry's Mod a little bit better. Not their fault addon / gamemode developers are lazy and haven't been keeping up to date with this thread, or even the changelog on the wiki (which is incredibly useful).
[QUOTE=dbk21894;47292878]I really like this update and hold nothing against Robotboy and Killburn for making Garry's Mod a little bit better. Not their fault addon / gamemode developers are lazy and haven't been keeping up to date with this thread, or even the changelog on the wiki (which is incredibly useful).[/QUOTE] Every update brings drama. It's really unavoidable. I guess post-hotfix drama is next.
[QUOTE=dbk21894;47292878]I really like this update and hold nothing against Robotboy and Killburn for making Garry's Mod a little bit better. Not their fault addon / gamemode developers are lazy and haven't been keeping up to date with this thread, or even the changelog on the wiki (which is incredibly useful).[/QUOTE] I understand that its mostly the developers fault for being "lazy" andnot testing there gamemodes/addons on the devbuild so they wouldn't have these issues when the update came but if am right isn't one of the most issues that devs are currently having are with the nw's? If am right wasn't that the thing killburn was suppose to fix before the update came out and such devs wouldn't have "Months" of time to test there gamemode/addons since as soon as killburn fixed them the update would come? [QUOTE=Mercior;47292838]Just going to throw in here that my gamemode, GangWarsRP is also broken with randomly crashing servers. I also wanted to question the logic of blaming developers because we didn't test your release. Obviously, if this version has been up for "6 months" and available for us to test - and yet NOBODY DID - then there is a flaw with this idealised vision of how to test updates? Personally, I host on dedicated machines and I don't really have the resources to host another srcds instance just for testing a dev branch that doesn't get a lot of attention and may not be released for months. Plus, how I could convince my players to install the test client for gmod and go onto this empty server, I don't know? At Unity Game Engine they have a similar issue that when they release updates they have the potential to break a lot of peoples games. So they have implemented an automated testbed system where they keep copies of some of the more popular games made within unity which are executed by the testbed (and in unities case, inputs are replicated into the game), logging error outputs and taking screengrabs. This is repeated on the current live code, and the developer branch of code. At the end the testbed can compare differences in the screenshots or errors logged, and flag up potential problems with the new update code! I accept this is a fair bit of work but I wanted to highlight that the idea of gmod devs like myself testing seemingly doesn't work, and that there are alternatives available.[/QUOTE] Is there not a way that we could perhaps mimic what unity game engine does it and do it for Garrys mod perhaps to lessen the amount of issues people have after these long awaited "Big Updates" [QUOTE]Personally, I host on dedicated machines and I don't really have the resources to host another srcds instance just for testing a dev branch that doesn't get a lot of attention and may not be released for months. Plus, how I could convince my players to install the test client for gmod and go onto this empty server, I don't know?[/QUOTE] I also wanted to point out is that you can't blame every developer for not testing their gamemodes/dev build because that would require constant checking and testing of the dev build and not everyone has the time to do that, Secondly people who have popular gamemodes like Mercior does with gangwarsrp and as he said himself [QUOTE]Plus, how I could convince my players to install the test client for gmod and go onto this empty server, I don't know?[/QUOTE] not everybody has the fine time to test there gamemodes and it makes it extremely hard for gamemode creators to test them by themselves.
Was there a reason to give a type specific NWvar a type that is different to what it expects pre-update?
The last 2 times my server has crashed, the usual "[B]Steam_: Saved dump file to 'garrysmod\srcds_blah.mdmp[/B]'" message is printed but SRCDS never actually closes like it did pre-update. It just sits there and doesn't get restarted by serverdoc unless I manually close it. I don't recall this ever occurring while my server was on the dev branch over the last half a year. Is this occurring for anyone else? I've kept up with all of the thread replies and don't think I've seen anyone else say anything about it, but I may have missed them.
[QUOTE=NiandraLades;47286959]Is anyone else having this, or could indicate what it means? [img]http://i.imgur.com/Oq2oOSn.png[/img][/QUOTE] update: i was trying to update my server while it was still running and turning it off fixed it
So many random crashes now. Did the GMod devs even test this update on anything other than Sandbox?
I'm running an ancient DarkRP version, with modified wire that must be 6months + old, tons of random addons hacked together from pre-gmod13 and yet somehow everything works perfectly with no server crashes, on linux Debian. Shockingly surprised considering I didn't test the dev branch at all, been way to busy recently. However... Few folks on Mac OS X are crashing on join, but no info on that.
hi everyone, I run a custom gamemode and since the update I get random server crashes and it decides to reboot itself, some errors are: [ERROR] lua/includes/modules/gamemode.lua:86: attempt to index upvalue 'hook' (a nil value) (not sure how to fix this since I have not even touched anything in here? probably a reference?) [ERROR] gamemodes/ourgamemode/gamemode/modules/pocket/cl_inventory.lua:123: bad argument #1 to 'pairs' (table expected, got nil) [ERROR] gamemodes/ourgamemode/gamemode/modules/base/sv_cdealer.lua:282: bad argument #2 to 'SetNWString' (string expected, got nil) [ERROR] gamemodes/ourgamemode/gamemode/modules/f4/cl_menu.lua:1659: bad argument #1 to 'GetBonePosition' (number expected, got no value) [ERROR] gamemodes/ourgamemode/gamemode/modules/base/sv_cdealer.lua:240: Tried to use a NULL entity! [ERROR] gamemodes/ourgamemode/gamemode/modules/base/sv_profilename.lua:126: bad argument #2 to 'SetNWString' (string expected, got nil) [ERROR] gamemodes/ourgamemode/entities/weapons/arrest_stick.lua:133: attempt to call method 'Team' (a nil value) [ERROR] addons/dlogs/luadeaglelogs/hooks/playerdeath.lua:29: attempt to call method 'Team' (a nil value) I think the main thing that's breaking it all is: bad argument #2 to 'SetNWString' (string expected, got nil) - but all this was working before the updates, could someone explain why on earth I am getting nil values yet before the update it was working. I am using basic things like ply:SetNWString is there anything wrong with using that? Has it been removed or something?
SetNWString now has to actually take a string. If you try and pass nil to it not an actual string it just errors. Also that "custom gamemode" oddly looks like DarkRP with a copy a deaglelogs installed. [editline]10th March 2015[/editline] Also for the hook thing update your anticheat.
ok Thanks meharryp :downs: yes its not fully custom since we love deaglelogs but even that has broken, thanks for the help though
Renamed DarkRP with scripts != Custom gamemode.
Sorry, you need to Log In to post a reply to this thread.