• gm_sourcenet3 - Advanced Source Networking Library
    203 replies, posted
  • Avatar of ColdFusion
  • [QUOTE=Buggzie;28871492]Yes it is, his module gets unloaded and then the crash happens. He knows about this, also no hacks and its not a listen server.[/QUOTE] Clientside always had that problem, this fix was related to the stack overflow for dedicated servers. Also i dont think its a very good idea using gmcl_disconnect.dll i combination with sourcenet. Also i suppose you are running it from the menu state ?
  • Avatar of Buggzie
  • [QUOTE=ColdFusion;28871594]Clientside always had that problem, this fix was related to the stack overflow for dedicated servers. Also i dont think its a very good idea using gmcl_disconnect.dll i combination with sourcenet. Also i suppose you are running it from the menu state ?[/QUOTE] I'm running disconnected from menu state, yes. But not sourcenet
  • [QUOTE=Buggzie;28870405][url]http://dumps.garrysmod.com/?view=847637057&refresh=15[/url] Still crashes, sorry :([/QUOTE] According to that dump you weren't even running sourcenet
  • How would I use sourcenet to send inconnect user IPs to clients when someone connects?
  • [QUOTE=.\\Shadow};28918402]How would I use sourcenet to send inconnect user IPs to clients when someone connects?[/QUOTE] If you meant to say incorrect then look at examples/sn3_stripip.lua
  • [QUOTE=Chrisaster;28918702]If you meant to say incorrect then look at examples/sn3_stripip.lua[/QUOTE] Yep, thanks :buddy:
  • My server seems to crash like, 5x as much with this installed (using the new ACP anti cheat). Some dumps: [url]http://dumps.garrysmod.com/?view=3420059248&refresh=5[/url] [url]http://dumps.garrysmod.com/?view=3183473488&refresh=2[/url] [url]http://dumps.garrysmod.com/?view=2102495518&refresh=4[/url]
  • Avatar of ColdFusion
  • [QUOTE=jimbodude;28952705]My server seems to crash like, 5x as much with this installed (using the new ACP anti cheat). Some dumps: [url]http://dumps.garrysmod.com/?view=3420059248&refresh=5[/url] [url]http://dumps.garrysmod.com/?view=3183473488&refresh=2[/url] [url]http://dumps.garrysmod.com/?view=2102495518&refresh=4[/url][/QUOTE] It crashes now and then, for us it went from 5 times a day to once a 6* days in the latest update. So make sure you have the latest version Only sourcenet related dump afther update: [url]http://dumps.garrysmod.com/?view=3386493904&refresh=4[/url]
  • Just downloaded latest version, and still crashing quite a bit. Less than I was, but still more than usual: [url]http://dumps.garrysmod.com/?view=606159081&refresh=3[/url] [url]http://dumps.garrysmod.com/?view=3364070542&refresh=4[/url]
  • [QUOTE=jimbodude;28956050]Just downloaded latest version, and still crashing quite a bit. Less than I was, but still more than usual: [url]http://dumps.garrysmod.com/?view=606159081&refresh=3[/url] [url]http://dumps.garrysmod.com/?view=3364070542&refresh=4[/url][/QUOTE] Could you send me those dumps? TIA.
  • [QUOTE=jimbodude;28956050]Just downloaded latest version, and still crashing quite a bit. Less than I was, but still more than usual: [url]http://dumps.garrysmod.com/?view=606159081&refresh=3[/url] [url]http://dumps.garrysmod.com/?view=3364070542&refresh=4[/url][/QUOTE] Could you send me those dumps? TIA.
  • Avatar of Python1320
  • error loading module 'sourcenet3' from file '/home/srcds/srcds/orangebox/garrysmod/lua/includes/modules/gm_sourcenet3_linux.dll': /home/srcds/srcds/orangebox/garrysmod/lua/includes/modules/gm_sourcenet3_linux.dll: undefined symbol: META_IGameEventManager2_name
  • [url]http://dumps.garrysmod.com/?view=1106510087&refresh=1[/url] Been getting a far few recently, oh as I typed this I see updated sign, maybe I should try it ;)
  • Avatar of Baaleos
  • past few days I have been getting errors on players joining, about invalid datastreams? Could the recent gmod updates have changed their networking methods? Unhandled Stream - slv_checkvalid etc
  • Avatar of Python1320
  • It's just some over-eager clientside addon. I can't remember which. As long as the stream is called "slv_checkvalid" it's nothing to worry about.
  • The latest revision contains a fix for the INVALID_POINTER_READ crash on the server. It was a problem in the Lua base code which led to deleted net channels being used.
  • I hope you can fix it when you have sourcenet3 loaded and you get kicked or the map changes, the client will crash.
  • [QUOTE=G-Foce85;30651884]I hope you can fix it when you have sourcenet3 loaded and you get kicked or the map changes, the client will crash.[/QUOTE] Send me the crash dump if you are using the latest version.
  • Avatar of Spacetech
  • Had to disable it since this latest update. Here's a dump: [url]http://dumps.garrysmod.com/?view=684562381[/url]
  • I've fixed the net messages code for a recent update (not this one), however it doesn't seem to have stopped the crash for anyone but me. Is anyone else having problems?
  • Severside works fine, Clientside is the one that worries me because I get a crash when kicked/map change. I'll upload a dump when I can.
  • Avatar of Gfoose
  • Serverside is crashing with funny lua errors and sometimes it's just "NULL" or lua error: No crash dumps are being generated, the server just restarts. I'm only using the strip ip example as well. 10:43:47 L 07/14/2011 - 10:44:24: Lua Error: string 10:47:40 L 07/14/2011 - 10:48:18: Rcon: "lua_openscript autorun/sn3_stripip.lua" 10:47:40 L 07/14/2011 - 10:48:18: Lua Error: attempt to concatenate a boolean value 10:47:40 Running script autorun/sn3_stripip.lua... Attach: CNetChan_Shutdown Attach: CNetChan_ProcessMessages Attach: CNetChan_SendDatagram 10:47:41 HLSW NOTE: Disconnected
  • [QUOTE=jellybaby34;31132859]Crashes on client when kicked or map changes. Sent dump to you via PM.[/QUOTE] The dump you sent doesn't contain any useful information and I still can't recreate it, so I'm not sure what I can do. [QUOTE=Gfoose;31083644]Serverside is crashing with funny lua errors and sometimes it's just "NULL" or lua error: No crash dumps are being generated, the server just restarts. I'm only using the strip ip example as well. 10:43:47 L 07/14/2011 - 10:44:24: Lua Error: string 10:47:40 L 07/14/2011 - 10:48:18: Rcon: "lua_openscript autorun/sn3_stripip.lua" 10:47:40 L 07/14/2011 - 10:48:18: Lua Error: attempt to concatenate a boolean value 10:47:40 Running script autorun/sn3_stripip.lua... Attach: CNetChan_Shutdown Attach: CNetChan_ProcessMessages Attach: CNetChan_SendDatagram 10:47:41 HLSW NOTE: Disconnected[/QUOTE] I can't really look into this without a dump or a way to recreate it.
  • Avatar of jellybaby34
  • The only way I can think that the reason why the client crashes for others but not you is that it uses something that we don't have that you do but this is just my guess at it. Or maybe we have something running that does it but that is more unlikely.
  • Avatar of Gfoose
  • [QUOTE=Chrisaster;31151369]The dump you sent doesn't contain any useful information and I still can't recreate it, so I'm not sure what I can do. I can't really look into this without a dump or a way to recreate it.[/QUOTE] Hows it going, did you find a way to fix it crashing? ( to everyone that doesn't know, i showed him the bug properly, apparently its a hook being spammed too much )
  • I found the problem. Since a recent update, Source seems to start using separate threads to send datagrams after 3 players (or some other condition is met) are connected. I'm writing a fix now.