• Contraption Damage Engine
    643 replies, posted
  • Avatar of cbale2000
  • [QUOTE=HighOnSinz;23726393]Both of my shields say Invalid Combination if I attempt to link them to a node in RD3.[/QUOTE] Yeah, they don't seem to work with RD3. That coupled with my overall loathing of V3, made me switch back to RD2.
  • Avatar of denizine
  • What's all this? I've gotten it to work fine with RD3/LS3. I haven't had to in a while, having to link all this stuff up got annoying, but I've made it work. I think it involves using the right tool or something.
  • Avatar of The_Final_Stand
  • Just use the regular link tool, and link the weapon/shield to the node as per usual. Link up an energy generator (Solar or wind works well). Wire up a button to "Fire". Press Button. Watch as stuff goes splodey.
  • found a nice way to 'get around' having to wire the shields up to a resource cache- wire shield to a constant value chip of 1 or higher. :D
  • Avatar of Lv100Garchomp
  • [QUOTE=XanyholesagoalX;23776009]found a nice way to 'get around' having to wire the shields up to a resource cache- wire shield to a constant value chip of 1 or higher. :D[/QUOTE] That's been known for a while.
  • Avatar of HonorGuard
  • Supposedly there's a way to make a sort of cinematic style death for your contraptions, where there are multiple explosions all over the place before your contraption finally dies. Is there some special way to set that up? I don't see a "cinematic death" option I can click.
  • Avatar of oooESTEBANooo
  • [QUOTE=HonorGuard;23786181]Supposedly there's a way to make a sort of cinematic style death for your contraptions, where there are multiple explosions all over the place before your contraption finally dies. Is there some special way to set that up? I don't see a "cinematic death" option I can click.[/QUOTE] It's a console comand, search through all the comands CDE has and you will find one or two to activate for this
  • Avatar of HonorGuard
  • [QUOTE=oooESTEBANooo;23788091]It's a console comand, search through all the comands CDE has and you will find one or two to activate for this[/QUOTE] Are they sort of obvious So I'll Know I've found them, or will I need to tinker a bit? [editline]10:27PM[/editline] Nevermind, found them.
  • Avatar of fstab
  • [QUOTE=HonorGuard;23789983]Are they sort of obvious So I'll Know I've found them, or will I need to tinker a bit? [editline]10:27PM[/editline] Nevermind, found them.[/QUOTE]I like reading the readme too. [/offtopic] Does anyone know if CDS3 by SnakeSVx still f***s up when you're trying to build? Last time I tried to use it, it kept setting my spawned props physical properties to something random, set their weights to 1 (they fell really slowly), and made them fade out and disappear after about 8 seconds. It seemed as though the damage control code was thinking they were being destroyed, even though they were just being spawned on flatgrass. :byodood: Either way, I like CDE better, so you don't have to worry about me going over to CDS3 (when or if it's fixed) ;)
  • Avatar of Ananace
  • I was looking through the shields and I noticed they actually have no check for seeing if "sv_CDamage_weapons_RDenabled" is on or off. Could that be a part of the fixes, I happen to enjoy my shields on servers without resources.
  • Avatar of Arania
  • Sorry about the long delay since the last update. Just moved house and the new place doesn't have internet or phone connected yet. [QUOTE=Tru Blu Sky;23235585]Needs more sexy de-activation / shut-down animation for the shields.[/QUOTE] Been working on it for a while now. Still trying to get something that looks good. [QUOTE=Silencer59;23654622]Interesting... I was sifting through some of the lua files for PewPew and it adds functions to E2 so that you can use it to get the health of a target entity. Would there be any possibility of something similar in CDE? It would eliminate the need for the health meter and also eliminate any future need for a health or shield scanner against other contraptions. Would probably use simple functions like "Ent:isShielded()" and "Ent:cdeHealth()". Just a suggestion. :P[/QUOTE] Good Idea, I'll see what I can put together for it. [QUOTE=HonorGuard;23786181]Supposedly there's a way to make a sort of cinematic style death for your contraptions, where there are multiple explosions all over the place before your contraption finally dies. Is there some special way to set that up? I don't see a "cinematic death" option I can click.[/QUOTE] The two you're looking for are 'sv_CDamage_epiccontraptiondeath' (which increases the death explosion size and removes wreckage) and 'sv_CDamage_delayeddeathexplosion' (which causes the popping explosions prior to death). The readme included with the addon has more info. [QUOTE=ace13;23852478]I was looking through the shields and I noticed they actually have no check for seeing if "sv_CDamage_weapons_RDenabled" is on or off. Could that be a part of the fixes, I happen to enjoy my shields on servers without resources.[/QUOTE] The check for that particular cvar occurs in a seperate code file, and only applies to weapons. The main reason the cvar doesn't affect shields is because players are allowed to set the health of their shields manually, and if resource consumption is turned off for the shield, there is very little to stop someone from creating a maximum-health shield (in essence, the resource demand acts as game balance) However, if you DON'T have RD2 or RD3 installed on your server, the shield will still function normally (the code managing the RDEnabled Cvar also takes care of testing if RD is installed)
  • Cinematic death explosions that can take more than 5 minutes to complete for large contraptions, such as space stations (Can be toggled off for a more fast-paced combat style) <-- that's sv_CDamage_epiccontraptiondeath right ? Since it appears that it didn't work properly for me then, not extremely big, however quite size on a ship, not with a lot of stuff since it was just a test ship. However, only one explosion, the thing went black, and 20 seconds later it dissapeared. No cinematic or anything like it. If I'm mistaken, then .. please tell me how, hehe. *Settings* [CODE] "CVARS" { "sv_CDamage_wreckage" "1" "sv_CDamage_wreckage_timeout" "30" "sv_CDamage_wreckageintegrity" "-1" "sv_CDamage_forcewreckfragementation" "0" "sv_CDamage_delayeddeathexplosion" "1" "sv_CDamage_epiccontraptiondeath" "1" "sv_CDamage_debrisviolence" "1" "sv_CDamage_contraptiondamage" "1" "sv_CDamage_damagemultiplier" "1" "sv_CDamage_enthealthmultiplier" "1" "sv_CDamage_maxenthealth" "10000" "sv_CDamage_overrideGcombat" "1" "sv_CDamage_overrideCDS" "1" "sv_CDamage_overridePewPew" "1" "sv_CDamage_weapons_RDenabled" "1" "sv_CDamage_shield_activationthresshold" "25" } [/CODE]
  • Avatar of HonorGuard
  • XanyholesagoalX- I'm sorry but your avatar disturbs me. Freaky looking pop-out eyeballs... *shudders* That aside I just want to make sure I'm doing this right- is it sv_CDamage_delayeddeathexplosion=1 or 'sv_CDamage_delayeddeathexplosion' '1'
  • [QUOTE=HonorGuard;23923855]XanyholesagoalX- I'm sorry but your avatar disturbs me. Freaky looking pop-out eyeballs... *shudders* [/QUOTE] lol, i made it as part of my GCSE art coursework :)
  • Avatar of HonorGuard
  • Figured it out, I need to use sv_CDamage_delayeddeathexplosion 1. [editline]02:35PM[/editline] [QUOTE=XanyholesagoalX;23935103]lol, i made it as part of my GCSE art coursework :)[/QUOTE] I'm sure the professor/teacher was amused with it. [editline]02:39PM[/editline] [QUOTE=Revelator;23866611]Cinematic death explosions that can take more than 5 minutes to complete for large contraptions, such as space stations (Can be toggled off for a more fast-paced combat style) <-- that's sv_CDamage_epiccontraptiondeath right ? Since it appears that it didn't work properly for me then, not extremely big, however quite size on a ship, not with a lot of stuff since it was just a test ship. However, only one explosion, the thing went black, and 20 seconds later it dissapeared. No cinematic or anything like it. If I'm mistaken, then .. please tell me how, hehe. *Settings* [CODE] "CVARS" { sv_CDamage_wreckage 1 sv_CDamage_wreckage_timeout 30 sv_CDamage_wreckageintegrity -1 sv_CDamage_forcewreckfragementation 0 sv_CDamage_delayeddeathexplosion 1 sv_CDamage_epiccontraptiondeath 1 sv_CDamage_debrisviolence 1 sv_CDamage_contraptiondamage 1 sv_CDamage_damagemultiplier 1 sv_CDamage_enthealthmultiplier 1 sv_CDamage_maxenthealth 10000 sv_CDamage_overrideGcombat 1 sv_CDamage_overrideCDS 1 sv_CDamage_overridePewPew 1 sv_CDamage_weapons_RDenabled 1 sv_CDamage_shield_activationthresshold 25 } [/CODE][/QUOTE] [B]Fixed[/B] If you had the quotations before everything like "sv_yaddayadda" "1" then that's why it didn't work. No quotation marks needed.
  • Avatar of MPSGA
  • Excuse me, but PLEASE EXPLAIN me how to use the shield. I've done it that way(not working): Create dome shield. Create RD3 resnode, link them together, add zpm, link it, add energy container, and what next? Pressing E on shield doesn't help. Wiring Power doesn't help... HELP!
  • Avatar of cbale2000
  • [QUOTE=MPSGA;23989736]Excuse me, but PLEASE EXPLAIN me how to use the shield. I've done it that way(not working): Create dome shield. Create RD3 resnode, link them together, add zpm, link it, add energy container, and what next? Pressing E on shield doesn't help. Wiring Power doesn't help... HELP![/QUOTE] Last I checked the shields don't work with RD3, only RD2. Though I think there is also a console command you can use so that they don't use energy, which could bypass the problem for you. Also, pressing E never does anything on the shields or weapons, they always require wire.
  • Avatar of MPSGA
  • [QUOTE=cbale2000;23990026]Last I checked the shields don't work with RD3, only RD2. Though I think there is also a console command you can use so that they don't use energy, which could bypass the problem for you. Also, pressing E never does anything on the shields or weapons, they always require wire.[/QUOTE] And that means I can't use it... Too bad...
  • Avatar of Arania
  • [QUOTE=HonorGuard;23941535]Figured it out, I need to use sv_CDamage_delayeddeathexplosion 1.[/QUOTE] You need to type it into the console when the game is running. Also, did you read the reply I gave? I told you BOTH of the convars you needed to use. Changing the entry in the file called 'damageengine_cvars.txt' (which is what I'm assuming you were doing, considering you posted the information from that file in your post) will do absolutely nothing. The values listed in that file are only read in and applied the first time the addon is used, changing it after that will have no effect. Also, the quote marks [I]are[/I] neccessary, please do not remove them. [QUOTE=MPSGA;23989736]Excuse me, but PLEASE EXPLAIN me how to use the shield. I've done it that way(not working): Create dome shield. Create RD3 resnode, link them together, add zpm, link it, add energy container, and what next? Pressing E on shield doesn't help. Wiring Power doesn't help... HELP![/QUOTE] I'm not quite sure what problem you're having. You will need to place down a resource node, a power generator of some sort, a power storage device, and a shield, and link everything to the resource node. You then wire the 'Power' Input on the shield to something that will output '1', and the shield should charge and activate. If it does not, it could indicate a problem with either CDE or RD3, or that you are not producing enough power to maintain the shield. [QUOTE=cbale2000;23990026]Last I checked the shields don't work with RD3, only RD2. Though I think there is also a console command you can use so that they don't use energy, which could bypass the problem for you. Also, pressing E never does anything on the shields or weapons, they always require wire.[/QUOTE] Everything in CDE works with both RD2 and RD3.
  • Avatar of gemmeg1
  • [QUOTE=Arania;23999898]You need to type it into the console when the game is running. Also, did you read the reply I gave? I told you BOTH of the convars you needed to use. Changing the entry in the file called 'damageengine_cvars.txt' (which is what I'm assuming you were doing, considering you posted the information from that file in your post) will do absolutely nothing. The values listed in that file are only read in and applied the first time the addon is used, changing it after that will have no effect. Also, the quote marks [I]are[/I] neccessary, please do not remove them. I'm not quite sure what problem you're having. You will need to place down a resource node, a power generator of some sort, a power storage device, and a shield, and link everything to the resource node. You then wire the 'Power' Input on the shield to something that will output '1', and the shield should charge and activate. If it does not, it could indicate a problem with either CDE or RD3, or that you are not producing enough power to maintain the shield. Everything in CDE works with both RD2 and RD3.[/QUOTE] Hey I was wondering when is the next release going to be with the cloak?
  • Avatar of cbale2000
  • [QUOTE=Arania;23999898]I'm not quite sure what problem you're having. You will need to place down a resource node, a power generator of some sort, a power storage device, and a shield, and link everything to the resource node. You then wire the 'Power' Input on the shield to something that will output '1', and the shield should charge and activate. If it does not, it could indicate a problem with either CDE or RD3, or that you are not producing enough power to maintain the shield. Everything in CDE works with both RD2 and RD3.[/QUOTE] I was playing around with this again tonight and got some interesting results, apparently I can connect the shields directly to a Black Hole Cache and it will work fine, however, if I have a working LS2 setup using resource caches, generators, etc.; as soon as I connect the shield, the ENTIRE system shuts down, all the generators stop running, and no resources go anywhere. If I recall correctly, this was basically the same issue I had had with LS3 when I used it a while back too, but didn't realize it till now, the difference is in LS2 you can hook the shield up to the BHC directly, in LS3 you can't (not being able to get this mod working in LS3 was the main reason I "upgraded" back to LS2).
  • Avatar of MPSGA
  • I got it working now. But it seems that it isn't blocking fire from Laser 2.0, Turret and maybe something else too. Stargate Staff Cannon works, though with the shield. Is it possible to change the shield color into a white one and what does the lower model selection box in Dome Shield options means? Seems that the Color box doesn't work either.
  • Avatar of oooESTEBANooo
  • [QUOTE=MPSGA;24034986]I got it working now. But it seems that it isn't blocking fire from Laser 2.0, Turret and maybe something else too. Stargate Staff Cannon works, though with the shield. Is it possible to change the shield color into a white one and what does the lower model selection box in Dome Shield options means? Seems that the Color box doesn't work either.[/QUOTE] Because this shield isn't intended to block those, only the weapons from the pack are fully compatible to use with the shield. Some SBEP have been added, I think.
  • This may have been answered already, but is there any way to output the health of the contraption with wire? If not there should be an sensor entity that reads and outputs the health, or maybe as an output of the shield generator?
  • Avatar of oooESTEBANooo
  • [QUOTE=Hyperion17;24179694]This may have been answered already, but is there any way to output the health of the contraption with wire? If not there should be an sensor entity that reads and outputs the health, or maybe as an output of the shield generator?[/QUOTE] In fact, there is. Look in the entities tab, and you will see the contraption health sensor (with another name I tink), under the CDE section. If you have too many entities and can't find it, then search more...
  • Ah didn't think to check under entities, I thought it would be with the rest of the CDE stuff. Well then, this addon is now the best damage engine Ive ever used ;)
  • Avatar of BoxMonster
  • Could you add an option where, once the entire contraption's health reaches zero, each prop starts to take regular GCombat/PewPew damage? Would extend fights a little bit, and make them more interesting. I just miss the ability to selectively destroy my opponent. >:]
  • Avatar of MPSGA
  • Is it normal that Contraption Engine Shield makes the world literally whacko? I mean, in gm_construct, for example, it makes those waterside levels(I mean the hills) to appear at insane places, you can see them, you can't touch them, and you can only see them at certain views.
  • Avatar of DrMiles
  • Hi, I've been facing some LUA error while using the CDE weapons such as light/heavy pulse cannons and artillery (missile launcher, beam cannon and torpedoes work perfectly fine) [CODE] [@addons\cde\lua\entities\base_weapon_projectile\init.lua:46] bad argument #1 to 'SetAngles' (Angle expected, got Vector) [/CODE]