• Spacebuild 3
    1,240 replies, posted
  • Avatar of andy4848
  • That would be nice. It would be really nice if planets could actually be round so that you can walk on the top/bottom/sides but I don't think it is possible to change the rotation of the player and their view and make it not laggy. Or I might just make some maps myself instead of complaining.
  • Avatar of regena
  • [QUOTE=creec]Please run benchmark program 3dmark06 and tell me your score. Use demo from here: [url]http://www.futuremark.com/benchmarks/3dmark06/download/[/url][/QUOTE] I will if i can remember to do so after getting home from my vacation.
  • Avatar of Levybreak
  • [QUOTE=andy4848]That would be nice. It would be really nice if planets could actually be round so that you can walk on the top/bottom/sides but I don't think it is possible to change the rotation of the player and their view and make it not laggy. Or I might just make some maps myself instead of complaining.[/QUOTE] Abandoned project Ulysses Universe managed it...somehow. It was never released, though.
  • Avatar of snake_1_1
  • [QUOTE=tomato3017]Snake, I think you should make a simplified mode of SB3 for those who want it. I know one of the big turnoffs I am hearing about is the increase in complexity. Having a SB2 like version of SB3(called SB3 LE maybe) might help as it gives the benefits of SB3(resource nodes, terraforming, etc) without the complexity of resources. This would help IMHO with an overall adoption of SB3 ~My 2 cents[/QUOTE] Added a Convar called SB_StaticEnvironment. 1 = Resources won't go up or down using the default system. 0 = Default, resources will go up/down....
  • Avatar of Fredo
  • For some reason I can't go noclip. It only happens when playing Spacebuild 3. The commands like sb_noclip are set to 1, so that isn't the problem. I thought that maybe the v key got unbound, but it was fine when playing sandbox. This happened when I updated it about an hour ago, though I haven't played Spacebuild 3 in a while so it would have happened before. EDIT: Nevermind, sbox_noclip was set to 0, though I don't know why.
  • Avatar of LimEJET
  • Pretty sure this has been asked before, but the gamemode refuses to start. With SB3 selected, the gamemode still becomes sandbox. When SB3 is on override, the gamemode changes to Base. What to do?
  • Avatar of creec
  • [QUOTE=LimEJET]Pretty sure this has been asked before, but the gamemode refuses to start. With SB3 selected, the gamemode still becomes sandbox. When SB3 is on override, the gamemode changes to Base. What to do?[/QUOTE] That means you have broken version of gamemode. Get new.
  • Avatar of Chris122990
  • Also, make sure there are no spaces in the folder containing SB3. For example, "Spacebuild 3" will fail, but "Spacebuild3" will work.
  • Avatar of LimEJET
  • [QUOTE=Chris122990]Also, make sure there are no spaces in the folder containing SB3. For example, "Spacebuild 3" will fail, but "Spacebuild3" will work.[/QUOTE] oOoh. Thankew.
  • Avatar of ColonelCorn
  • A cool idea for ships could be a working drop pod. Not something that does flips while it's in the air and lands on its side. Could possibly be done by making headcrab canisters into a vehicle and giving them a different model (Not the prop headcrab canisters oblivously, the ones that slam into the ground).
  • Avatar of LimEJET
  • [QUOTE=ColonelCorn]A cool idea for ships could be a working drop pod. Not something that does flips while it's in the air and lands on its side. Could possibly be done by making headcrab canisters into a vehicle and giving them a different model (Not the prop headcrab canisters oblivously, the ones that slam into the ground).[/QUOTE] There is already drop pods in the SBEP. Go look for it.
  • Avatar of ultradr3mer
  • [offtopic] I hope you know that there is no GeForce 200 or 9000 they all use the old 8000 Gpu they only renamed it. ATI would have the best Graohic Card ever if the only made better drivers. But if i were ATI I would allso don't change drivers for gta4. Why should they fix their game. When they can't deliver a code that works after all that time its their fault. When I can't make a website that works I should not hope that the firefox gets an update to display my website. [/offtopic] Some footage of a map project i had some time ago. [img]http://ultradr3mer.ul.funpic.de/MyHompage/uploads/sb_lost_worlds_earth0182.jpg[/img] [img]http://ultradr3mer.ul.funpic.de/MyHompage/uploads/sb_lost_worlds_earth0179.jpg[/img] [img]http://ultradr3mer.ul.funpic.de/MyHompage/uploads/sb_lost_worlds_earth0181.jpg[/img] [img]http://ultradr3mer.ul.funpic.de/MyHompage/uploads/sb_lost_worlds_earth0180.jpg[/img] maybe you think why sb ... Because the sky is only a model and it actually has even night [img]http://ultradr3mer.ul.funpic.de/MyHompage/uploads/sb_lost_worlds_earth0184.jpg[/img] [img]http://ultradr3mer.ul.funpic.de/MyHompage/uploads/sb_lost_worlds_earth0183.jpg[/img] would be fine if all maps use this... and here is the reason why sb is so laggy... [url]http://ultradr3mer.ul.funpic.de/MyHompage/uploads/sb_lost_worlds_earth0054.jpg[/url] unneeded polygons on evry prop.
  • Avatar of creec
  • [QUOTE=ultradr3mer][offtopic] I hope you know that there is no GeForce 200 or 9000 they all use the old 8000 Gpu they only renamed it. [/QUOTE] I have e9800 gtx + And that almost beats best ati gpu if i turn proper overclock on. It is not renamed, but it shouldn't be 9000 i agree. It should be named 8900 series, but nvidia wanted to end those 8xxx and 9xxx series and start from 3 digit 1xx series. You are wrong if you think you can beat my gpu with some crappy nvidia 8800 :) PS: If you want to try, run 3dmark06 and link me to score or post screenshot. [/OFFTOPIC] [b]Edit:[/b] By the way, nice map. Can't wait to try. [b]Edit:[/b] [QUOTE=ultradr3mer] and here is the reason why sb is so laggy... [url]http://ultradr3mer.ul.funpic.de/MyHompage/uploads/sb_lost_worlds_earth0054.jpg[/url] unneeded polygons on every prop.[/QUOTE] That's right, unneeded polygons. But SB3 is not laggy, compared to SB2 which crashed every 5 min. In SB2 every connection created new resource node. Think of it: 2 entities - 2 nodes - 2 connections 3 entities - 3 nodes - 6 connections 10 entities - 10 nodes - 90 connections average spaceship with 30 entities - 30 nodes - 870 connections (now where did that lag come from?) You can see that most lag was caused by calculations and processes run by entities, not by graphics level or polygon count. If you don't trust me, run SB2 create bunch of entities link together and make them invisible. (that stops drawing them and so disables lag caused by graphics) You will see that SB2 was mess. In SB3 there is only one node in one contraption so 30 entities will make 29 connections.
  • Avatar of ColonelCorn
  • [QUOTE=LimEJET]There is already drop pods in the SBEP. Go look for it.[/QUOTE] But that one spins and flips in the air, and when it hits the ground it tips (all of which ruin epic moments :()
  • Avatar of regena
  • [QUOTE=ultradr3mer] ATI would have the best Graohic Card ever if the only made better drivers. [/QUOTE] Hate to break it to you. Even though it is multiple video cards in an external case the quadro plex by nvidia would currently make any gamer happy if it was more compatible and less expensive. [url]http://www.nvidia.com/page/quadroplex.html[/url] [off topic] Other than that the map looks very good.
  • Avatar of Galaxy613
  • Where is the SVN for this? It's not in the first post... I'm assuming there's a SVN because 10+ servers are already hosting this.
  • Avatar of creec
  • [QUOTE=Galaxy613]Where is the SVN for this? It's not in the first post... I'm assuming there's a SVN because 10+ servers are already hosting this.[/QUOTE] Not sure if there is public svn yet, but everyone is getting it from: [url]www.glua.net[/url]
  • Avatar of amitakartok
  • [QUOTE=creec]Not sure if there is public svn yet[/QUOTE] Probably not, as a thread I read an hour ago says that it's in beta phase. But if there's that source, then they're wrong. [b]Edit:[/b] [QUOTE=creec]In SB2 every connection created new resource node. Think of it: 2 entities - 2 nodes - 2 connections 3 entities - 3 nodes - 6 connections 10 entities - 10 nodes - 90 connections average spaceship with 30 entities - 30 nodes - 870 connections (now where did that lag come from?) You can see that most lag was caused by calculations and processes run by entities, not by graphics level or polygon count. If you don't trust me, run SB2 create bunch of entities link together and make them invisible. (that stops drawing them and so disables lag caused by graphics) You will see that SB2 was mess. In SB3 there is only one node in one contraption so 30 entities will make 29 connections.[/QUOTE] Sounds good. However, some older addons doesn't have a SB3-compatible version, sadly. For example, a reliable resource transportation (like in RD transit addon: resources are packed into color-coded packets which can be linked up normally) would be nice. [B]EDIT:[/B] Does someone know whether SB3 can save and reload normally, not fully messed up like SB2 (though that one has a solution, but I don't like to unlink everything prior to save)?
  • Avatar of Galaxy613
  • [QUOTE=creec]Not sure if there is public svn yet, but everyone is getting it from: [url]www.glua.com[/url][/QUOTE] Ah, thanks a whole lot. :) Also it's glua.net, not .com (I googled 'glua' after finding out glua.com was wrong)
  • Avatar of creec
  • [QUOTE=Galaxy613]Ah, thanks a whole lot. :) Also it's glua.net, not .com (I googled 'glua' after finding out glua.com was wrong)[/QUOTE] LOL, sorry i don't use that place so much. :D
  • Avatar of GuyNumbers
  • The SVN links for everything you need are [url=http://snakesvx.blogdns.com/wikki.php?page=Help/Info/SVN]here[/url]. Also, can I make a suggestion (does snake read suggestions here?). Maybe have the life support environment regulators draw a sphere around themselves to indicate the area they effect, or draw the sphere around their ghosts while you're placing them. This would really help in placing life support systems in an efficient manner. Also, I've been getting [i]gamemode.think[/i] errors after I play in spacebuild for a while (single player). This happens when I try to turn on a life support machine. It complains about infinite loops being detected.
  • Avatar of Dippeggs
  • [QUOTE=GuyNumbers;13165765]The SVN links for everything you need are [url=http://snakesvx.blogdns.com/wikki.php?page=Help/Info/SVN]here[/url]. Also, can I make a suggestion (does snake read suggestions here?). Maybe have the life support environment regulators draw a sphere around themselves to indicate the area they effect, or draw the sphere around their ghosts while you're placing them. This would really help in placing life support systems in an efficient manner. Also, I've been getting [i]gamemode.think[/i] errors after I play in spacebuild for a while (single player). This happens when I try to turn on a life support machine. It complains about infinite loops being detected.[/QUOTE] I got that stuff, but I can't find any generators or storage devices in my menu! I have everything else, including models.
  • Avatar of Ark_gamer
  • Would it be possible to make an alternate version of SB3 that kept all the physics but ditched the life support? LS3 has gotten ridiculously bloated, I spend more time trying to generate resources to get to space than I actually do in space having fun. Someone tried this a while back (called it Spacebox) but mysteriously disappeared when people figured out how buggy it was. I just want to play around in space without all this extra LS baggage.
  • Avatar of Fredo
  • [QUOTE=Ark_gamer;13181249]Would it be possible to make an alternate version of SB3 that kept all the physics but ditched the life support? LS3 has gotten ridiculously bloated, I spend more time trying to generate resources to get to space than I actually do in space having fun. Someone tried this a while back (called it Spacebox) but mysteriously disappeared when people figured out how buggy it was. I just want to play around in space without all this extra LS baggage.[/QUOTE] You don't actually need to use Life Support you know. You can turn it off. Go to the Custom Addon Framework tab in the Q menu and then click on the main menu for it. From there go to server settings and you can turn everything off.
  • Avatar of *Freezorg*
  • [QUOTE=GuyNumbers;13165765]The SVN links for everything you need are [url=http://snakesvx.blogdns.com/wikki.php?page=Help/Info/SVN]here[/url]. Also, can I make a suggestion (does snake read suggestions here?). Maybe have the life support environment regulators draw a sphere around themselves to indicate the area they effect, or draw the sphere around their ghosts while you're placing them. This would really help in placing life support systems in an efficient manner. Also, I've been getting [i]gamemode.think[/i] errors after I play in spacebuild for a while (single player). This happens when I try to turn on a life support machine. It complains about infinite loops being detected.[/QUOTE] I don't want an SVN. I want a .zip.