• Spacebuild 3
    1,240 replies, posted
  • Avatar of Killer_Steel
  • Ah the all inclusive memory bug, that's a bug in Garry's code, since it happens to happen randomly, with any shape of addons placed on the server. Sadly, it's not a problem with the addons, it's a problem with the game itself.
  • Avatar of samohan
  • [QUOTE=Killer_Steel;15288972]Ah the all inclusive memory bug, that's a bug in Garry's code, since it happens to happen randomly, with any shape of addons placed on the server. Sadly, it's not a problem with the addons, it's a problem with the game itself.[/QUOTE] does this normaly affect only one file of part of an addon? with this error it only affects SBEP's large elevator, I'll look for their forum though.
  • Avatar of Killer_Steel
  • I believe it does have something to do with SBEP as I have the same bug...have you traced it so the dev team can fix it?
  • Avatar of Hibikar
  • Greetings, Does this thread deal with LS3 aswell? If not, I apologize, but I've encountered a problem. I recently updated all of my LS3 SVN's, and the Custom Addon Framework svn doesn't seem to work anymore. Has anyone else had this occur? Does anyone know if the svn url has been moved, or something? I cannot find a more appropriate place to ask this, as there are no threads, websites, or forums even, with up-to-date information on LS3.
  • Avatar of Hibikar
  • Ah! I checked there, but apparently I didn't dig deep enough. I found the thread mentioning the URL change now, thanks. (For anyone else having the same problem, it's now [url]http://customaddonframework.googlecode.com/svn/trunk[/url] )
  • Avatar of snake_1_1
  • [QUOTE=BoxMonster;15303603]Found a pretty major bug in LS3... This the place for it? O.o[/QUOTE] You can post it here to, since LS is mostly used with Sapcebuild anyways;) Update: Made some fixes to the gas generators, ram scoops and fixed problems with the temperature and air exchangers... Changelog link: [url]http://www.snakesvx.net/forum/viewtopic.php?f=22&t=71&p=247[/url]
  • Avatar of amitakartok
  • Now it's my turn: I downloaded everything correctly, yet the mining addon refuses to work. Everything else works except that one. CAF says the ever-so-descriptive "there was a problem blahblahblah" and the console says ABSOLUTELY NOTHING.
  • Avatar of lord-garn
  • The mining addon, doesn't work by default as far as I know because nobody has worked on it. You just get the loading error from the initial start-up. If you really wanna see, sb_gooniverse is the only map that something spawns on. You get 3 ultra laggy roids inside each other on earth, and 3 piles of metal u can mine in the dome of the cliffs on earth.
  • Avatar of BoxMonster
  • Okay, with certain generators selected on the Generator tool, like the Eversmart H2O Splitter or Large Water Pump, the console gets spammed with "Spawn: Entity [number][prop_physics]" at several times per second, eventually crashing the game with a "no free edicts" error...
  • Avatar of snake_1_1
  • [QUOTE=BoxMonster;15318307]Okay, with certain generators selected on the Generator tool, like the Eversmart H2O Splitter or Large Water Pump, the console gets spammed with "Spawn: Entity [number][prop_physics]" at several times per second, eventually crashing the game with a "no free edicts" error...[/QUOTE] I'll check it out. Could you give me a list of models that have this problem? So I can more easily compare....
  • Avatar of amitakartok
  • [QUOTE=lord-garn;15311069]The mining addon, doesn't work by default as far as I know because nobody has worked on it. You just get the loading error from the initial start-up. If you really wanna see, sb_gooniverse is the only map that something spawns on. You get 3 ultra laggy roids inside each other on earth, and 3 piles of metal u can mine in the dome of the cliffs on earth.[/QUOTE] I see. Well, thanks for the info anyway.
  • Avatar of BoxMonster
  • [QUOTE=snake_1_1;15323237]I'll check it out. Could you give me a list of models that have this problem? So I can more easily compare....[/QUOTE] The ones that I gave, Eversmart H2O Splitter and CE Large Water Pump, are the only two that I know of, but I [i]think[/i] there are more. I'll check it out next time I play...
  • Avatar of snake_1_1
  • Been checking into it, talking to some other people. And apparently they have encountered the same problem. Only fix so far seems to be either to disable the Ghosting or to find a way around it. I reported it on the garry'smod bugtracker. But we'll have to wait till Garry can check out what wrong. The problem is that it only seems to happen with certain models, so it could be a model related bug somehow...
  • Avatar of pokeman
  • I've just reinstalled this and there's a few problems. I put all the folders except the spacebuild3 one into addons and made sure to remove all the sb2 stuff. But in game the when I'm in space there's no gravity (good) but there's air (bad), the little hud thing never shows up too. Also the CAF menu is there but the LS part is empty except for grav plating, the RD part is there though. Any ideas?
  • Avatar of DrMiles
  • [QUOTE=pokeman;15361761]I've just reinstalled this and there's a few problems. I put all the folders except the spacebuild3 one into addons and made sure to remove all the sb2 stuff. But in game the when I'm in space there's no gravity (good) but there's air (bad), the little hud thing never shows up too. Also the CAF menu is there but the LS part is empty except for grav plating, the RD part is there though. Any ideas?[/QUOTE] Same problem here. No LS entites, except GravPlating. And most of RD3 and LS3 tools spam console with errors like [code] weapons\gmod_tool\ghostentity.lua:8: bad argument #1 to 'PrecacheModel' (string expected, got nil) [/code] [strike]Plus, CAF svn says this: Error: REPORT request failed on '/svn/!svn/vcc/default' Error: Target path does not exist [/strike] RIP Custom addon framework SVN. maybe total cleanup off all SB3 directories and re-downloading will help...
  • Avatar of Morcam
  • CAF SVN Moved, if that's what you mean. Get the new link off of snakesvx.net wiki pages.
  • Avatar of That Ninja
  • My friend and I can't access our Q menus in multiplayer. He started it up in singleplayer, and he could access the Q menu. I started a listen server, and I couldn't access the menu, so then HE starts a listen server. HE can't access the Q menu. What's wrong?
  • Avatar of lotus006
  • [QUOTE=That Ninja;15403450]My friend and I can't access our Q menus in multiplayer. He started it up in singleplayer, and he could access the Q menu. I started a listen server, and I couldn't access the menu, so then HE starts a listen server. HE can't access the Q menu. What's wrong?[/QUOTE] Maybe the selected gamemode or you have put in the wrong place SB3 try to move the SB3 folder in GameMode and not Addons, or look if is there an info.txt in the folder at the parent directory
  • Avatar of pokeman
  • I'm trying changing to the new CAF SVN, see if that works... [B]EDIT:[/B] Oh it worked by the way. After building with it for a bit I found out the hard way that habitable parts don't dupe. Whats the deal with that? I much prefer to use them over regulators and stuff, they don't make a massive bubble of air in space which kills the realism for me. But if you can't dupe them then you basically can't use them.
  • Avatar of Hexalude
  • How do I install this? I have put it under gamemodes and addons and it still does not show up as a playable mode in single player. Help welcomed, smart arse remarks not.
  • Avatar of Morcam
  • [QUOTE=Hexalude;15480474]How do I install this? I have put it under gamemodes and addons and it still does not show up as a playable mode in single player. Help welcomed, smart arse remarks not.[/QUOTE] See, there's this thing called an installation guide, conveniently located at [url]http://www.snakesvx.net/index.php/module_Wiki/title_Garrysmod_Help_Installation_Morcam[/url]
  • Avatar of Hexalude
  • How versatile of you, you were both helpful and a smart arse. EDIT: Worked like a charm though, thank you.
  • Avatar of Morcam
  • [QUOTE=Uberman77883;15488052]Life support 3 sucks ass.[/QUOTE] Your short, unsupported statement sucks ass.