• Weird textures in Gmod?
    29 replies, posted
  • Avatar of concerned112
  • I just started playing Gmod on Gm_Construct and for some reason every shiny surface in the map is covered in very large, and distant looking pink and black checkerboard thingy. It just suddenly happened when I joined a multiplayer game. Very strange. Any one know what it is? Or how to fix it?
  • Avatar of Sticker
  • Pink and Black checkerboard is a sign of a graphic problem related to your graphics card. Usually this is just to much memory being processed, so your computer likes to give you a lovely checkerboard. Most of the time, restarting GMod, reconnecting to the server or refreshing your video settings will fix this. Try also if this isn't working to lower your video settings a tad.
  • [QUOTE=Sticker]Pink and Black checkerboard is a sign of a graphic problem related to your graphics card. Usually this is just to much memory being processed, so your computer likes to give you a lovely checkerboard. Most of the time, restarting GMod, reconnecting to the server or refreshing your video settings will fix this. Try also if this isn't working to lower your video settings a tad.[/QUOTE] Don't you just love people who speak out of their ass?
  • Avatar of concerned112
  • [QUOTE=PredatorKing]Don't you just love people who speak out of their ass?[/QUOTE] What do you mean?
  • Avatar of chris0132
  • He means it's wrong. Pink and black is the source error texture, if your computer had run out of memory, gmod would crash with a memory error. It's not related to your graphics card even if it [I]is[/I] a memory error. The shiny surfaces suggests it's a cubemap problem. This occasionally occurs in a number of situations, usually when you minimse the program and reopen it later, avoid doing this. Restarting the game will fix the error.
  • Avatar of Owosso
  • Yeah, I have this problem quite frequently. If I close GMod and re-open it, though, it works fine. Other people said that minimizing the game will cause this to happen, but I need to minimize the game in my situation (but that's a whole 'nother story in a different thread)...
  • The black and pink checkerboard texture essentially means 'the texture is missing'. Most games have some sort of texture which the surface or polygon defaults to when a texture is missing or corrupted. Try doing a fresh reinstall of Gmod. Are you trying to run an older or custom version of gm_construct that possibly uses textures from a .gcf archive which you've deleted/un-installed/no longer exists?
  • Avatar of FwankFwank
  • Hey I keep getting the same problem with SLAM's, u know, the little laser tripmine things. I've restarted Gmod plenty of times, and it still shows up with the pink and black checkerboard texture. What should I do?
  • Avatar of SGTNAPALM33
  • Fwank, you need to buy hl2. So people like you and me just can not use those weapons. Deal. Also, the checkerboard texture in the Construct and Flatgrass levels are often caused by a glitch in an add on that you download. Just remove the add ons you recently installed to fix that.
  • Avatar of N0 WAR
  • [QUOTE=concerned112]I just started playing Gmod on Gm_Construct and for some reason every shiny surface in the map is covered in very large, and distant looking pink and black checkerboard thingy. It just suddenly happened when I joined a [b]multiplayer[/b] game. Very strange. Any one know what it is? Or how to fix it?[/QUOTE] Does that mean that it works in singleplayer?
  • Avatar of Ketila
  • I get that problem whenever the server i am on crashes, but alt-tab out of gmod and back again fixes it. other times i use the the console command that reloads textures. It was mat_reload something
  • umm. This is a little off topic but my shiny material doesn't work anymore. It just shows up as white. I have all the source games, So I don't know why it doesn't work. So does anyone have an idea.
  • Avatar of baker256
  • i mainly only get it when i'm on a gooniverse server every time i go to the lava planet the surface is all checkerboard except the lava in the middle also on the main planet if i go under the water the screen turns into a checkerboard
  • I found a fix for the underwater missing textures. and I also figured out my shiny material not working,kidna, it doesn't work very good on gm_construct, but on any other map its fine. oh well. Heres a link to the water fix. [url]http://www.garrysmod.org/downloads/?a=view&id=36002[/url]
  • i have glitch were i look at one spot and it looks like a material and when i change angles it changes to either black or white, also on gm_consruct my grass/ground it like spotted bright green of almost white
  • [QUOTE=spiderninja]i have glitch were i look at one spot and it looks like a material and when i change angles it changes to either black or white, also on gm_consruct my grass/ground it like spotted bright green of almost white[/QUOTE] I think that might be a graphics card problem. I get that sometimes too. do the map and all props become transparent?
  • Avatar of DannyM
  • What the pink and black checkerboard thing means your missing the material.Well I think sometimes
  • Avatar of Sgt Sarcasm
  • Whenever I try to make somthng big n GMOD (like 100 entites or pretty much any wire things) the screen is covered in weird random colored bars. Is ths just because of the graphics card not being good enough or is it somthng i can fix?
  • Avatar of locutus_1
  • i have a similar problem, in the right upper corner i get small checkerboard square then after a min all the single player starts exit game and so on turns to the pink and black squares this is only after like 2 min of playing then it will freeze and crash... any ideas? or fixes? my video card dosent do this to crysis or any other game just gmod if you have links post em please
  • Avatar of flyingturtles
  • Say if you didnt have css, and there was a css object like a wall or something because you dont have that game it would show up black and pink. All above is wrong.
  • Avatar of CoolCorky
  • How do people keep finding threads that are this old? And thankyou flyingturtles, we established that two years ago. As for locutus, try verifying your Gmod cache. You probably have textures missing.
  • Avatar of noman_ex
  • You will be amazed by how they do it. On neoseeker forum someone answered a two years old thread. It's almost like they are actively seeking questions that they can answer on Google. Probably some sort of OCD.
  • Avatar of nicatronTg
  • To be honest, with people being banned for "Use the search!" they probably think that if they bump an old thread they can still ask and show that they used the search without getting banned. I will admit that I've been banned for "Use the search" when there was a single topic in 07 un-replied to that had my question in it.
  • Flyingturtles, you are totally wrong, if there is a mesh from CSS, and you don't have CSS ( like you don't have the game.. ) you will see a big red 3D text and it says : "ERROR" wich means : Model Missing. (Object Missing.) If you have the game object but you dont have the specified texture for it ( like in hl2 you have an container that is totally the same in CSS but the texture (Image) is different ) you will see a PINK & BLACK texture [highlight](User was banned for this post ("Dumb bump" - Gran PC))[/highlight]
  • [QUOTE=roman8880;36515931]Flyingturtles, you are totally wrong, if there is a mesh from CSS, and you don't have CSS ( like you don't have the game.. ) you will see a big red 3D text and it says : "ERROR" wich means : Model Missing. (Object Missing.) If you have the game object but you dont have the specified texture for it ( like in hl2 you have an container that is totally the same in CSS but the texture (Image) is different ) you will see a PINK & BLACK texture[/QUOTE] Yes this was established four years ago.