• PlayX player not working
    6 replies, posted
  • Avatar of Jova
  • I used to use the PlayX Player all the time on my old server, and I just recently started up another sandbox server and I'd like to use playx but it's not working for some reason that is way beyond my thoughts. When I play any video on the PlayX Player, the screen goes black and I can only hear the sound of the video, but I can't view the video. I've tried updating flash player using firefox and installing it using IE (my friend said to get it for IE) and I've tried other things but It doesn't work for some reason. One of my friends said garry changed something that may have broken it for me. Any ideas?
  • Avatar of DatMeg
  • Are you using the latest stable version? There is an SVN for it ([url]http://wiki.garrysmod.com/?title=SVN_Links#PlayX[/url])
  • Avatar of Code3Response
  • 1: [url]http://wiki.github.com/sk89q/playx/frequently-asked-questions[/url] 2: [release][b]Troubleshooting[/b] [i]Seeing Black/White[/i] Make sure that you have Flash player installed for “other browsers.” Installation page: [url]http://get.adobe.com/flashplayer/otherversions/[/url] Make sure that the playx_jw_url cvar on the server is set to [url]http://playx.googlecode.com/svn/jwplayer/player.swf[/url] Make sure that the playx_host_url cvar on the server is set to [url]http://sk89q.github.com/playx/host/host.html[/url] Go to [url]http://sk89q.github.com/playx/host/host.html[/url] in your browser and check to see if it is working. (It is a black page.) Go to [url]http://playx.googlecode.com/svn/jwplayer/player.swf[/url] in your browser and check to see if it tries to download something (don’t download it). Sometimes the site that hosts that file is unavailable. If you are still having trouble, please post on the Facepunch thread for PlayX.[/release]
  • Avatar of Hyperion01
  • But where to change the cvar? [highlight](User was banned for this post ("Dumb bump" - Orkel))[/highlight]
  • Avatar of mutle
  • I have the same problem. And i did saw another post about this. It is because the new update(s?). Let's try this solution and see if it works... By the way, the SVN link is not working. (page does not exist)
  • Avatar of Hyperion01
  • Okay so I checked that cvar thingy and it's okay. I also downloaded and installed the Flash or what was it for other browsers. But still not working in multiplayer. I don't care about singleplayer, because then I can play my music player. Anyone have an Idea how to make a jukebox through Wire to replace this? A single speaker playing several, user defined songs?
  • Alright. Spawnmenu > Options > PlayX > Administrate. Set Provider to "non browsable page", enter a video into the URL part and press open media. Then, to watch videos like you normally do, just do !ytplay "vid". People who join after you've done the stuff above won't be able to see the player before you do the above again.