• Can sombody explain how to set up FastDL on Garry's Mod
    19 replies, posted
i need help on how to set it up to download my maps and custom stuff i have a webhost and all but i need help on how to do it please help me out
On your webhost, you need a folder named "garrysmod", and inside that folder is where you keep folders such as "materials", "models", "sound", etc. Have your sv_downloadurl point to that garrysmod folder. So in server.cfg, add a line like: [CODE]sv_downloadurl "http://www.yourdomain.com/garrysmod"[/CODE] so that when you type that url into your web browser, you come to the barebones file browser showing you the materials, models, and sound folders.
Note that if you are adding a model or texture from an addon, you don't put it in /addons, you put it directly in models on the fastdl server. Fastdl doesn't read /addons
[QUOTE=Cep.;38930960]On your webhost, you need a folder named "garrysmod", and inside that folder is where you keep folders such as "materials", "models", "sound", etc. Have your sv_downloadurl point to that garrysmod folder. So in server.cfg, add a line like: [CODE]sv_downloadurl "http://www.yourdomain.com/garrysmod"[/CODE] so that when you type that url into your web browser, you come to the barebones file browser showing you the materials, models, and sound folders.[/QUOTE] Always when i set it up, the content never downloads to my cliënt. Does someone know how to fox this?
[QUOTE=Poop2heaven;38933425]Always when i set it up, the content never downloads to my cliënt. Does someone know how to fox this?[/QUOTE] Are you sure you have resource.AddFile in your gamemode pointing to the correct filenames?
[QUOTE=Cep.;38934327]Are you sure you have resource.AddFile in your gamemode pointing to the correct filenames?[/QUOTE] Yes, the file name is "recourses.lua" and it's located in lua\autorun
download_debug 1 developer 4 connect to the server, paste the output of the console here in [code][noparse][code][/code][/noparse][/code] tags
[QUOTE=Banana Lord.;38943140]download_debug 1 developer 4 connect to the server, paste the output of the console here in [code][noparse][code][/code][/noparse][/code] tags[/QUOTE] [QUOTE] Connected to 192.168.0.98:27015 DarkRP Map: rp_downtown_v2 Players: 1 / 25 Build: 5141 Server Number: 1 FCVAR_CHEAT cvars reverted to defaults. OrangeRP - ActiveAdmins/LotsOfFun/WorkInProgress darkrp rp_downtown_v2 25 76561198031387423 Unhandled GameEvent in ClientModeShared::FireGameEvent - server_spawn Requesting 5 lua files from the server Loading: maps/rp_downtown_v2.bsp No pure server whitelist. sv_pure = 0 Initializing renderer... SOLID_VPHYSICS static prop with no vphysics model! (models/props_lab/corkboard001.mdl) Couldn't find customization file 'sound/player/jingle.wav'. clientside lua startup! You are running ULib version 2.50. [ULIB] Loading SHARED module: ulx_init.lua [ULX] Loading CLIENT module: motdmenu.lua [ULX] Loading CLIENT module: uteam.lua [ULX] Loading CLIENT module: xgui_client.lua [ULX] Loading CLIENT module: xgui_helpers.lua [ULX] Loading CLIENT module: xlib.lua [ULX] Loading SHARED module: chat.lua [ULX] Loading SHARED module: fun.lua [ULX] Loading SHARED module: menus.lua [ULX] Loading SHARED module: rcon.lua [ULX] Loading SHARED module: teleport.lua [ULX] Loading SHARED module: user.lua [ULX] Loading SHARED module: userhelp.lua [ULX] Loading SHARED module: util.lua [ULX] Loading SHARED module: vote.lua Client "My Ass" spawned in server (192.168.0.98:27006)<STEAM_0:1:35560847>. ULX version <SVN> unknown revision loaded. Welcome to OrangeRP - ActiveAdmins/LotsOfFun/WorkInProgress! We're playing rp_downtown_v2. [DarkRP] My Ass (STEAM_0:1:35560847) has joined the game "materials/__vgui_texture_2.vtf": can't be found on disk Set Gravity 600.0 (0.250 tolerance) Signon traffic "CLIENT": incoming 82.807 KB, outgoing 7.842 KB Queued Material System: ENABLED! Compact freed 1839104 bytes /////////////////////////////////////// // ULX GUI -- Made by Stickly Man! // /////////////////////////////////////// // Loading GUI Modules... // // bans.lua // // commands.lua // // groups.lua // // maps.lua // // settings.lua // // Loading Setting Modules... // // client.lua // // server.lua // // Loading Gamemode Module(s)... // // sandbox.lua // // No module found! // // Modules Loaded! // /////////////////////////////////////// Redownloading all lightmaps R_RedownloadAllLightmaps took 105.188 msec! Noclip allowed[/QUOTE]
Did you run download_debug 1 developer 4
[QUOTE=Banana Lord.;38947254]Did you run download_debug 1 developer 4[/QUOTE] Yes, but now it somehow did download the models, i saw it downloading alot of .mdl files. But now i when i spawn it, i get errors and this is what comes up in the console. [QUOTE]Downloading [url]http://www.orangerp.comeze.com/garry...lor005.vtf.bz2[/url]. Error downloading [url]http://www.orangerp.comeze.com/garry...lor005.vtf.bz2[/url] Downloading [url]http://www.orangerp.comeze.com/garry...k/color005.vtf[/url]. Download finished! Downloading [url]http://www.orangerp.comeze.com/garry...lor001.vtf.bz2[/url]. Error downloading [url]http://www.orangerp.comeze.com/garry...lor001.vtf.bz2[/url] Downloading [url]http://www.orangerp.comeze.com/garry...e/color001.vtf[/url]. Download finished! Downloading [url]http://www.orangerp.comeze.com/garry...lor003.vtf.bz2[/url]. Error downloading [url]http://www.orangerp.comeze.com/garry...lor003.vtf.bz2[/url] Downloading [url]http://www.orangerp.comeze.com/garry...n/color003.vtf[/url]. Download finished! Downloading [url]http://www.orangerp.comeze.com/garry...lor002.vtf.bz2[/url]. Error downloading [url]http://www.orangerp.comeze.com/garry...lor002.vtf.bz2[/url] Downloading [url]http://www.orangerp.comeze.com/garry...d/color002.vtf[/url]. Download finished! Downloading [url]http://www.orangerp.comeze.com/garry...lor006.vtf.bz2[/url]. Error downloading [url]http://www.orangerp.comeze.com/garry...lor006.vtf.bz2[/url] Downloading [url]http://www.orangerp.comeze.com/garry...e/color006.vtf[/url]. Download finished! Downloading [url]http://www.orangerp.comeze.com/garry...lor004.vtf.bz2[/url]. Error downloading [url]http://www.orangerp.comeze.com/garry...olor004.vtf.bz[/url].[/QUOTE]
those all look fine, what models/materials aren't downloading?
[QUOTE=Banana Lord.;38948069]those all look fine, what models/materials aren't downloading?[/QUOTE] This: The only one that i can see not downloading are alot of bs2 files. They just fail downloading. But other then that, i can not find any files that are not downloading.
that just means that the compressed version of the file wasn't found so it looked for the non-compressed version to download. that isn't necessarily bad but it is nice to compress your files so players can join quicker
[QUOTE=Banana Lord.;38948574]that just means that the compressed version of the file wasn't found so it looked for the non-compressed version to download. that isn't necessarily bad but it is nice to compress your files so players can join quicker[/QUOTE] Allright it works now :D Anyway i got one more question for you, i have bzipped the map with bzip, but where do i place the rar file that i got?
[QUOTE=Poop2heaven;38948659]Allright it works now :D Anyway i got one more question for you, i have bzipped the map with bzip, but where do i place the rar file that i got?[/QUOTE] Players can only download BZ2 compressed files, not rar/zip/7z/any other formatS [editline]23rd December 2012[/editline] if you want to BZ2 compress files I recommend the [url=http://7-zip.org]7-Zip[/url] program, just make sure to change the format to BZ2 compression before creating the archive
[QUOTE=Cep.;38930960]On your webhost, you need a folder named "garrysmod", and inside that folder is where you keep folders such as "materials", "models", "sound", etc. Have your sv_downloadurl point to that garrysmod folder. So in server.cfg, add a line like: [CODE]sv_downloadurl "http://www.yourdomain.com/garrysmod"[/CODE] so that when you type that url into your web browser, you come to the barebones file browser showing you the materials, models, and sound folders.[/QUOTE] i have that but it doesnt work it only downloads my maps not materials and models?
Mister Banana Lord, I also haz a problem with my fastDL, I have it set up... it works.. except the models, _undefined said something about garry not fixing it yet like if your models and shit are in the folder and not in the root, they won't download. I use _undefined's pointshop, I added a Russian Hat in the pointshop, people can download it but they see purple/black checkered texteru (pink as some say) I did contact _undefined he is just too busy.
I can't testify to Undefined's pointshop but I have a gamemode and 2 addons recursively adding files in their folders (aka they aren't merged with the root directory structure) and it works fine. My only guess is that the casing doesn't match 100% between the webserver and the gameserver (most webservers are Linux, and Linux is case-sensitive). ie. [b]server:[/b] path: models/player/cop/policeman.mdl resource.AddFile( "Models/Player/Cop/PoliceMan.Mdl" ); [b]webserver:[/b] path: models/player/cop/policeman.mdl.bz2 that is not the same as [b]M[/b]odels/[b]P[/b]layer/[b]C[/b]op/[b]P[/b]olice[b]M[/b]an.[b]M[/b]dl
oh god, I see 2 problems I might have had... model is not bz2'd + I changed the actual models original path to an organized folder... I thought it should have no problems when I checked the models/model.mdl file I realised it had a connection with the texture of the materials/models/model.vmt file. You, KIND of helped me but then I helped myself, who cares here's a Wrench in your banana face!
I'm still having my issue but it worked fine before. It started happening after activating cloudflare than things started not downloading and giving the "HTTP error downloading" except some of them are there and some were not. The files that were there were not there "according to console" were there and the ones that were not there "were not there". I don't see why it won't work and I even put it in resources.lua and lua/autorun/server but it won't download to my clients. [highlight](User was banned for this post ("Bumping a 2-year old thread" - Megafan))[/highlight]
Sorry, you need to Log In to post a reply to this thread.