• WireMod for OSX
    10 replies, posted
  • Well,I have been playing some servers which had WireMod,But,When I join these server,I get notified that I am having an old version of WireMod,2248 I think,So I have found an WireMod Installer for Mac OSX([url]http://www.wiremod.com/forum/installation-malfunctions-support/22828-wiremod-svn-app-mac.html[/url]) but it doesn't work at all.When I Press install,It does nothing,And changes to 'Update Wire' even though,I didn't even install! So I have tried looking in Steam forums,And I have found that there's a way to install it via the Terminal Application just like this [CODE]cd ~/Library/Application\ Support/Steam/SteamApps/<YOUR STEAM USERNAME HERE>/garrysmod/garrysmod/addons/ svn co https://wiremod.svn.sourceforge.net/svnroot/wiremod/trunk/[/CODE] When it stops spazing (it'll take like 2 mins depending on your internet connection), type: [CODE] cd trunk mv Adv\ Duplicator .. mv wire .. mv wire\ model\ pack\ 1 .. cd .. sudo rm -r trunk svn co https://phoenix-storms.svn.sourceforge.net/svnroot/phoenix-storms/ [/CODE] The first commands work,But the other,I get asked that I need a password,Although I don't have any,So I just press enter(blank password) and it says that it is wrong,And without this stage,When I get to SP in Gmod,I see alot of Lua errors and there's an announcement which says that I didn't properly install WireMod... So can anyone help me with this,Please?
  • Avatar of BillyBob11432
  • I'd say just learn to use a normal SVN program. I don't use mac, but with enough googling you could find a decent one. First, go [URL="http://lmgtfy.com/?q=SVN%20mac"]here[/URL]. Then, once you've found a good SVN program, go [URL="http://wiki.garrysmod.com/?title=SVN_Links"]here[/URL] and add the Wire Complete SVN into your program.
  • I need some explanation,I can't understand how all this actually works! And thanks for replying!
  • Sorry for double-posting but this Topic can be removed,The thing i've done wrong is that I had all the old files of Wiremod,I just simply removed them from my addons folder,And tried their OneClickWM Application which easily installs WireMod for Mac and this time,It actually worked,Not like before. And thanks again BillyBob11432.
  • Avatar of supervoltage
  • You should still use SVN though, you don't have to go through the hassle of Delete->Place->Delete->Place etc. With SVN, you Place->Update->Update->Update and so on
  • Avatar of sicklebrick
  • Props for working out the gray matter on this one... but out of curiosity, did you try 'anonsvn' or 'anon' as passwords?
  • [QUOTE=sicklebrick;31303917]Props for working out the gray matter on this one... but out of curiosity, did you try 'anonsvn' or 'anon' as passwords?[/QUOTE] Your asking something that I don't really know how to reply to,I don't know much about the whole SVN process,I barely know how to do simple things with Wire itself... By the way,I have managed to get WireMod installed on my Mac...Didn't you read the Double-post I've submitted? But there's only one thing which bothers me,I can't use the Wire tool itself,That's the only tool that isn't working for me in Singleplayer,But in Multi it does...
  • Avatar of sicklebrick
  • [QUOTE=Danikov;31304690]Your asking something that I don't really know how to reply to,I don't know much about the whole SVN process,I barely know how to do simple things with Wire itself... By the way,I have managed to get WireMod installed on my Mac...Didn't you read the Double-post I've submitted? But there's only one thing which bothers me,I can't use the Wire tool itself,That's the only tool that isn't working for me in Singleplayer,But in Multi it does...[/QUOTE] Lol that's weird :S Try reinstalling maybe? The whole thing's not that big. What I was saying though was congrats on using your brain and actually attempting to use the command line tools (which work fine) before taking the easy route and just downloading a proggie. Nice to see someone try. As for the username and password, you said it asked for one but you didn't have it... I just suggested trying anon/anon or anonsvn/anonsvn. Sorry I can't be more help!
  • [QUOTE=sicklebrick;31305013]Lol that's weird :S Try reinstalling maybe? The whole thing's not that big. What I was saying though was congrats on using your brain and actually attempting to use the command line tools (which work fine) before taking the easy route and just downloading a proggie. Nice to see someone try. As for the username and password, you said it asked for one but you didn't have it... I just suggested trying anon/anon or anonsvn/anonsvn. Sorry I can't be more help![/QUOTE] Well,It appears to be that I have managed to install Wiremod properly,But I can't use the Wire tool itself in Singleplayer,In Multiplayer,The Wire Tool works...
  • Guys please help,I really want to get Wire Tool to get working on Singleplayer Btw,Whenever I enter the game,I see alot of .lua errors concerning the Wire Tool itself...
  • Sorry for replying/bumping again,But I found a solution,I need a Windows user to upload the Wire folder which includes the Wire Tool itself,And I might now get Wire Tool to work.