• Corpses disappear in gmod even though keep corpses is checked
    26 replies, posted
  • Avatar of cow8grass
  • Basically, I have keep corpses checked, yet after about 30 seconds, the corpse will disappear. The only thing I can think of, is that at one point, I had Gmod set to DirectX 7. I can change it to a higher level, if that is what solves the issue.
  • Avatar of cow8grass
  • Bump. It has nothing at all to do with too many ragdolls, because the issue can happen when only one is present.
  • Avatar of Gran PC
  • [QUOTE=cow8grass;33955516]Bump. It has nothing at all to do with too many ragdolls, because the issue happens when only one is present.[/QUOTE] I have no idea then. It'd help if you could reply to people's responses in a timely manner. Have you tried increasing your dxlevel (probably unrelated) and uninstalling your addons?
  • Avatar of cow8grass
  • [QUOTE=GranPC;33962245]I have no idea then. It'd help if you could reply to people's responses in a timely manner. Have you tried increasing your dxlevel (probably unrelated) and uninstalling your addons?[/QUOTE] I was on vacation from the holidays. DX level is set in the launch options to 90, and I've completely re-installed the game and used a clean addons folder, and gmod folder, to no avail.
  • Avatar of Juggernog
  • Probably sounds silly, but what are your specs, seen as you're playing with DirectX 7.
  • Avatar of cow8grass
  • Intel dual core 2.5GHz ATI Radeon HD 5570 4 Gigs of RAM Windows 7 550 watt Power supply I was on Direct X 7 because I was playing Fallout 3 and Gmod at the same time. Just to see if I could.
  • Avatar of AprilExpo
  • Make sure g_debug_ragdoll_removal is 0, otherwise, check g_ragdoll_fadespeed to see what its set to.
  • Avatar of cow8grass
  • [QUOTE=AprilExpo;34057572]Make sure g_debug_ragdoll_removal is 0, otherwise, check g_ragdoll_fadespeed to see what its set to.[/QUOTE] Fixed, thanks. I changed the fadespeed from 600 to 0.
  • Avatar of cow8grass
  • Problem is up again. I've tried all the fixes posted here, the corpses still vanish in about 30 seconds.
  • Avatar of brandonj4
  • [QUOTE=cow8grass;34406972]Bump.[/QUOTE] [URL="http://www.facepunch.com/threads/1068607?p=34084527&highlight=#post34084527"]http://www.facepunch.com/threads/1068607?p=34084527&highlight=#post34084527[/URL] Read this thread, next time try searching instead of just posting.
  • [QUOTE=brandonj4;34418456][URL="http://www.facepunch.com/threads/1068607?p=34084527&highlight=#post34084527"]http://www.facepunch.com/threads/1068607?p=34084527&highlight=#post34084527[/URL] Read this thread, next time try searching instead of just posting.[/QUOTE] Hey, jackass, he posted the original thread before that. The things to check in there he's already checked.
  • Bump. I found the solution! Bump. What a great catchphrase...anyways, there is a command called npcg_ragdoll_lifetime! If you set it to 999999999999999999999999 then the ragdolls should stick around long enough for your purposes. If you turn keep corpses off, they dissapear instantly...hope I helped! I had the same dilemna for a long time...
  • [QUOTE=McWindmill;41586925]Bump. I found the solution! Bump. What a great catchphrase...anyways, there is a command called npcg_ragdoll_lifetime! If you set it to 999999999999999999999999 then the ragdolls should stick around long enough for your purposes. If you turn keep corpses off, they dissapear instantly...hope I helped! I had the same dilemna for a long time...[/QUOTE] Thank You So Much! :dance:
  • [QUOTE=McWindmill;41586925]Bump. I found the solution! Bump. What a great catchphrase...anyways, there is a command called npcg_ragdoll_lifetime! If you set it to 999999999999999999999999 then the ragdolls should stick around long enough for your purposes. If you turn keep corpses off, they dissapear instantly...hope I helped! I had the same dilemna for a long time...[/QUOTE] it didn't work for me i don't want to re install addons or delete them because if i do then i won't remember half of the addons i have so i decided to try what you said but it still didn't work
  • [QUOTE=jonitah112;47856857]Update your server, trust me ;)[/QUOTE] how do i update my server?
  • [CODE]login anonymous force_install_dir (Then the directory your server files are installed to) app_update 4020 validate [/CODE]
  • [QUOTE=jonitah112;47857089][CODE]login anonymous force_install_dir (Then the directory your server files are installed to) app_update 4020 validate [/CODE][/QUOTE] thanks.....................
  • [QUOTE=jonitah112;47857089][CODE]login anonymous force_install_dir (Then the directory your server files are installed to) app_update 4020 validate [/CODE][/QUOTE] wait never mind the glitch is fixed thanks guys! :D bump is a good catchphrase...