• Camera tool spawns non-physical cameras.
    8 replies, posted
  • Avatar of PimpinDemopan
  • Okay, let's give this another go. A few months ago, I installed an advanced camera tool from Garrysmod.org. However, the lua file of it overwrote how the default camera tool operates. Now the camera tool spawns cameras as non-physical objects. They can't be moved or adjusted with the physgun, and their placement action can't be undone with the z key on the keyboard. I no longer have the advanced camera lua file, and the addon has been deleted from Garrysmod.org. My big question is this: Is there a way that I can reset the camera's scripting to how it was originally? I'm afraid that when Gmod 13 comes that my camera will still be broken. It's frustrating trying to do screenshots like this, and I have not been able to find a solution anywhere. If anyone reading this has the slightest clue as to how I can fix this, please, I'd very much appreciate the help.
  • Avatar of PimpinDemopan
  • So, I figured out how to better explain my camera problem: [url]http://www.garrysmod.org/downloads/?a=view&id=132240[/url] This tool is scripted to remove an object's physics and said object from the undo list. Somehow, the advanced camera lua I had did this exact same thing to the cameras the camera tool spawns. Does ANYBODY know how to re-add the physics to the cameras and the cameras back to the undo list?
  • Avatar of Lolcats
  • Did you re-install after you took out the addon? A fresh install of Garry's Mod will [i] generally [/i] work with no addons or custom shit. Just re-add each addon until you find the one that causes your cameras to bug out, then, well, don't use it.
  • Avatar of PimpinDemopan
  • No, and since I don't have the lua for the advanced camera anymore, if I reinstall it should work. But first I need an external to back my stuff up onto...
  • Avatar of DaneSomdahl
  • You can just delete the .lua files, since the defaults are in the GCF then those won't be overridden by any existing lua files relating to whatever you deleted and it should go back to default.
  • Avatar of PimpinDemopan
  • Um....if that had worked, I wouldn't have made this thread. Anyhoo, my new laptop arrived today, so I'll be soon transferring all my content to an external and then to the new laptop. A fresh install should do the trick. Wait, if it's in the GCF, I can just extract it and place it in the folder, right? That might fix it.