July 2017 Hotfix #2

This update fixes some insecure code and a crash related to models

25 July 2017

We've had a bunch of recent crash reports that were caused by specific models with invalid flex rules. These crashes could have been triggered by addons that utilise model flexes, voice chat mouth movement, or the faceposer tool. This shouldn't happen any more.

You can read about the vulnerability in the Source Engine that was discovered by One Up Security here. This is now fixed in Garry's Mod.

2017.07.25 July 25 2017
  • fixed

    Fixed crash when rendering models with invalid flex rules

  • fixed

    Fixed RCE exploit discovered by One Up Security

Mailing List

If you want to follow this project you can sign up to the mailing list.

We'll only update you about this project, we won't spam you about other stuff or sell your email address.